APPLICATIONS USING ARCVIEW 3.2

CHAPTER 4

The applications section covers methods for vector data input. Task 1 uses existing data on the Internet. Task 2 lets you digitize several polygons directly on the computer screen. Tasks 3 and 4 show you how you can generate a theme, from an ASCII file or a .dgn file so that the theme can be used in ArcView. The last two tasks require use of ARC/INFO. Task 5 is an exercise on raster to vector conversion using a scanned file. Task 6 is an exercise on geometric transformation.

Task 1: Download a digital map from the Internet

Like many other states, Idaho has a website that lets GIS users download ARC/INFO coverages in either export (e00) format or shapefile format. Maintained by the Idaho Department of Water Resources, the website also provides metadata for the coverages. Task 1 shows you how to import an export file in ArcView, and convert the imported coverage to a shapefile.


1.
Go to http://www.idwr.state.id.us/gisdata/, and click GIS Data. Then click Statewide Data.


2.
The Statewide Data table lists coverages that can be downloaded and the choices of Preview gif, e00, Shapefile, and Metadata. Click on Metadata for County Boundaries. The metadata gives you information about the coverage. Now RIGHT click on the dot for e00 and select “Save Link As” (or “Save Target As” using Internet Explorer) from the menu. Name the file idcounty.e00 and provide the path to save the file.


3.
The first part of this exercise is to import idcounty.e00 in ArcView. Select Import71 from the ArcView program group. In the import dialog, enter the path to idcounty.e00 for the Export File Name and the path to idcounty (name of the imported coverage) for the Output Data Source. Import71 converts the import file into an ARC/INFO coverage.


4.
Start ArcView, and open a new view. Navigate the path to idcounty and add the coverage to view. Check the box next to idcounty to view the coverage.


5.
Next you want to convert idcounty to a shapefile. Make idcounty active, and select Convert to Shapefile from the Theme menu. Name the shapefile idcounty.shp and specify its path. Add idcounty.shp to view. Idcounty.shp looks exactly the same as idcounty.

Task 2: On-Screen digitizing using ArcView

What you need: landuse.shp, a background map for digitizing.


On-screen digitizing is technically similar to manual digitizing. The differences are (1) you use the mouse rather than the digitizer’s cursor for digitizing, (2) the resolution of the computer monitor is much coarser than a digitizer, and (3) you need a coverage, a shapefile, or an image (e.g., a digital orthophoto) as the background for digitizing. This task lets you digitize several polygons off landuse.shp and make a new shapefile.


1.
Start ArcView, open a new view, and add landuse.shp to view. Select Properties from the View menu and select meters for both the Map Units and Distance Units. Landuse.shp is measured in meters and has been projected.


2.
Double click on landuse.shp in the Table of Contents to open its legend editor. Change the Legend Type to Single Symbol and the Symbol to a red, outline symbol. Then click Apply. The reason to symbolize landuse.shp in red is to distinguish it from the new shapefile you will digitize. You are not digitizing the entire landuse.shp for this task. Make landuse.shp active, and select Auto-label from the Theme menu. In the next dialog, select landuse_id for the Label Field. The polygons in landuse.shp are labeled from 59 to 77. For this task, you will digitize polygons 72–76 in the lower left (Figure 4.21).


3.
Select New Theme from the View menu. In the next dialog, select polygon for the Feature Type. Name the new shapefile trial.shp and specify its path. Notice the box next to trial.shp in the Table of Contents is in dashed lines, meaning that trial.shp is in edit mode. Double click on trial.shp to open its legend editor. Change the symbol for trial.shp to a black, outline symbol.


4.
To make sure that features you digitize will meet and align properly, you need to use interactive snapping options. Make trial.shp active. Select Properties from the Theme menu. In the Theme Properties dialog, click on Editing in the table of contents. This opens two dialogs for Attribute Updating and Snapping. For this task, you need to only work with Snapping. Check the box for Interactive, enter 10 (meters) for the Tolerance, and click OK. The snapping tolerance of 10 meters means that if you digitize two points (vertices) within 10 meters, for example, the two points will be snapped together. As you will see in the next step, 10 meters is a large tolerance for digitizing.


5.
Now you are ready to digitize trial.shp. Zoom in the area of polygons 72–76. Hold the Draw Rectangle tool down, and select Draw Polygon from the pull down menu. You have three digitizing options: left click on the mouse to digitize a point (vertex); right click on the mouse to open a popup menu, which contains such selections as Snap to Vertex and Snap to Intersection; and double click to finish digitizing. You can start with polygon 74: digitize vertices that make up its boundary. The last point you digitize for polygon 74 should be at the same location as the beginning point. Before you digitize the last point, right click on the mouse and select Snap to Vertex. The snapping tolerance (10 meters) that you have defined can now help you to snap the last point to the starting point. As soon as you double click the last point, handles appear around polygon 74. If you don’t like what you have digitized, you can press the Delete key to remove polygon 74 and start over.


6.
Polygon 74 shares a common border with polygon 75. So that you do not have to digitize the common border a second time, change the Draw Polygon tool to Draw Line to Append Polygon. To use this append tool, you must digitize the starting and end points of polygon 75 inside polygon 74 (Figure 4.22). Other than that, the procedure for digitizing is the same.


7.
Polygons 72, 73, and 76 are island polygons. To digitize an island polygon, you can start at any vertex and end at the same point.


8.
After you have digitized polygons 72–76, select Stop Editing from the Theme menu and save the edits.


9.
Finally, make sure trial.shp is active and select Table from the Theme menu. The table should have five records, one for each polygon you have digitized.

Task 3: Add Event Themes in ArcView

What you need: events.txt, a text file containing 
x-, y-coordinates of GPS readings.


Add Event Theme in ArcView adds a theme to view from an event table. An event table is essentially a text file that has x-, y-coordinates. The file events.txt is a text file that contains x-, y-coordinates of a series of points collected by GPS readings. Task 3 shows you how to use the file to create a new theme.


1.
Start ArcView and open a new view.


2.
Click on Tables and Add. In the Add Table dialog, first change the file type to Delimited Text and then select events.txt. The field Easting in events.txt is the x-coordinate and the field Northing the y-coordinate.


3.
Select Add Event Theme from the View menu. In the Add Event Theme dialog, specify Easting as the x field and Northing as the y field. Click OK. A new theme called events.txt is added to the Table of Contents. Check the box next to it and you will see the points collected from the GPS readings.

Task 4: Read a .dgn File in ArcView

What you need: boundary.dgn, a Microstation design file showing the state and county boundary of Idaho in two layers.


ArcView can read CAD (Computer Aided Design) drawing files and create new themes from them. The supported drawing file formats are Microstation design (.dgn) files and AutoCAD’s DXF and DWG files. Task 4 lets you read a simple .dgn file.


1.
Start ArcView and load the Cad Reader extension.


2.
Open a new view and select Add Theme from the View menu. In the next dialog, select Feature Data Source for the Data Source Type, navigate to boundary.dgn, and click OK.


3.
Check the box next to boundary.dgn to view it. Boundary.dgn consists of two layers: the state border and the county boundary. To view the two layers, do the following: double click boundary.dgn to open its legend editor, select Unique Value for the Legend Type and Layer for the Value Field, and click Apply. Layer 48 contains the state border, and Layer 47 contains the county boundary.

Task 5: Use Scanning for Spatial 
Data Input

What you need: hoytmtn_gd, an ARC/INFO grid converted from a scanned file.


As explained in the text, scanning for digitizing involves two steps: scanning and raster-to-vector conversion. Task 5 performs the second step. A scanned file is an image file, commonly in TIFF (Tagged Image File Format) or RLC (Run Length Compressed) format. Working with a grid, which uses ESRI’s proprietary format for raster data, is easier than working with an image file in ARC/INFO. A scanned file of a soil map has been converted to a grid called hoytmtn_gd for Task 5. In the following, you will convert hoytmtn_gd to an ARC/INFO coverage.


1.
Before going to ArcTools, you need to create an empty coverage hoytmtntrace that will eventually be filled with arcs from the tracing of hoytmtn_gd:

[ARC] create hoytmtntrace hoytmtn_gd


By specifying hoytmtn_gd as an argument in the CREATE command ensures that hoytmtntrace has the same map extent (BND) as hoytmtn_gd.


2.
Start ArcTools:



[ARC] arctools


3.
Select Edit Tools in the ArcTools menu and click OK.


4.
Select File in the Edit Tools menu, and select Grid Open in the File pulldown.


5.
Choose hoytmtn_gd in the Select an Edit Grid menu. Click OK. This action results in the display of hoytmtn_gd in the ArcEdit window, and the opening of the Grid Editing menu. The grid hoytmtn_gd contains text on data source. What you do in Steps 6–9 is to remove the text using the grid editing tools in ArcScan.


6.
Click the Sketch button in the Grid Editing menu to open the Sketch menu.


7.
Type 0 as the Fill value in the Sketch menu.

Note. Hoytmtn_gd is a bi‑level, or black‑and‑white, grid file. The fill value of 0 is the same as the background.

8.
Go to the ArcEdit window and use Extent in the Pan/Zoom pulldown to find the data source. Use Fullview to get the full view of hoytmtn_gd.


9.
After you see the data source clearly in the ArcEdit window, click on the fill tool (the Solid Square icon) in the Sketch menu. Press the mouse and drag a box around the data source. The data source disappears as you release the mouse.


10.
Select File in the Edit Tools menu, and select Coverage Open from the File pulldown.


11.
In the Select an Edit Coverage menu, click on hoytmtntrace in the Coverages list. Click the Create New Feature button to open the Create Feature menu.


12.
In the Create Feature menu, select Arc in the Feature Class list. Click Apply. This action adds Arc to the Available Feature list. Make sure that Arc remains highlighted.


13.
Zoom into hoytmtn_gd so that you can see lines in the ArcEdit window.


14.
Click on the Trace button in the Edit Arcs & Nodes menu. Press the cursor at the start of a line along the border of hoytmtn_gd that is well connected with other lines. A green line appears at the starting point; it is called the tracer.

Note. As in manual digitizing, you do not want to trace the same line twice. That could happen if you select a starting point in the middle of an arc.

15.
Press 8 on the keyboard for semi‑automatic tracing. Lines that have been traced turned into green. The green lines then turn into yellow after all the connected lines to the starting point have been traced and the built‑in algorithms for line straightening and generalization have been applied to the traced lines.

16.
Lines that remain untraced in hoytmtn_gd are those of island polygons, polygons along the border, and tic marks. Click the Trace button in the Edit Arcs & Nodes menu, press the cursor along an untraced line, and press 8 on the keyboard.

17.
Repeat the above step until all lines are traced. Each time you press the cursor at a point, the tracer appears; you can change the tracer direction by middle clicking on the mouse. Left click on the mouse switches to the option of manual tracing. Manual tracing allows you to trace one line segment at a time.

Note. You need to change the tracer direction often in manual tracing because you trace one arc at a time.
18.
Select File in the Edit Tools menu, and select Coverage Save in the File pulldown. This saves hoytmtntrace with its traced lines.

Task 6: Use TRANSFORM on a newly digitized map in ARC/INFO

What you need: a digitized soils map called hoytmtn, and a text file called tic.geo.


The digitized map hoytmtn is measured in inches. It has four control points that correspond to the four corner points, with the following longitude and latitude values in degree-minute-second (DMS):


TIC-ID
LONGITUDE
LATITUDE


1
2116 00 00
47 15 00


2
2115 52 30
47 15 00


3
2115 52 30
47 07 30


4
2116 00 00
47 07 30


The text file tic.geo contains the longitude and latitude values of the four tics. (Open tic.geo to see how the file is prepared.) The first step is to use the PROJECT command with the file option to convert the longitude and latitude values in tic.geo into UTM coordinates and save the new coordinates in tic.utm.



[ARC] project file tic.geo tic.utm 



Project: input



Project: projection geographic



Project: units dms



Project: parameters



Project: output



Project: projection utm



Project: units meters



Project: zone 11



Project: parameters



Project: end


The choice of a real-world coordinate system is made through the PROJECT command. PROJECT is a dialog command, meaning that after you enter the command, you must provide projection parameters such as UTM zone by using PROJECT’s subcommands. The dialog, as shown in the preceding paragraphs, is organized into two sections. The first section describes the input data, and the second the output data. Each section ends with the subcommand of parameters to see if any parameters are required for the specified projection. In this case, no parameters are required for the geographic grid (i.e., longitude and latitude values) or the UTM coordinate system.


The output file, tic.utm, has the UTM coordinates of the four tics as follows:


Tic-ID
x
y

1
575672.2771
5233212.6163


2
585131.2232
5233341.4371


3
585331.3327
5219450.4360


4
575850.1480
5219321.5730

The next step is to create an empty coverage, hoytmtn2, by copying the tics and the bnd from hoytmtn:






[ARC] create hoytmtn2 hoytmtn

The tics of hoytmtn2 are measured in inches, similar to those of hoytmtn. But with the output from the PROJECT command you can now use the update command in Tables to update the tics of hoytmtn2 to their UTM coordinates. The final step is to use TRANSFORM to convert the rest of the coverage into UTM coordinates by using the tics as control points:



[ARC] transform hoytmtn hoytmtn2

