APPLICATIONS USING ARCVIEW 3.2

CHAPTER 8

This applications section consists of three tasks. The first task guides you through the process of making a choropleth map in ArcView, first in black-and-white and then in color. Task 2 involves type design, graduated symbol, choice of color combination, and use of highway shield symbols. Task 3 focuses on the placement of text.

Task 1: Making a Choropleth Map 

What you need: us.shp, a U.S. theme showing population change by state between 1990 and 1998. The theme is projected onto the Albers equal-area projection and is measured in meters.


Choropleth maps display statistics by administrative units. For this task you will map the rate of population change between 1990 and 1998 by state. The emphasis of Task 1 is on the use of graduated color in ArcView. 


1.
Start ArcView, open a new view, and add us.shp to view. 


2.
Select Properties from the View menu. Change the name to “Population Change By State, 1990–98,” change the Map Units to meters, and click OK. The name of the view will be the title on your map. Select Properties from the theme menu. Change 
the theme name to “Percentage Change,” and click OK. The name of the theme will 
appear as the description for the theme legend.


3.
Double-click the theme name to invoke the Legend Editor. Select Graduated Color from the Legend Type pull-down menu. Select “Zchange,” which contains the percent change data between 1990 and 1998, for the Classification Field. Click Apply. The default map uses five classes and the red monochromatic color scheme. 


4.
The default data classification uses the natural break method and five classes. You can change the number of classes or the classification method by clicking on Classify in the Legend Editor to open the classification dialog. The scroll bars for Type and Number of Classes let you change the classification method and the number of classes, respectively. 


5.
You can also change the class breaks in the Legend Editor. To change the class breaks, click on a value cell, type in the class breaks you want, and press Enter. Make sure the class breaks you type in do not have gaps between them; otherwise, you may find some states are not symbolized in the map. Cartographers recommend round numbers such as 5.0 instead of odd numbers such as 5.3 in data classification. Cartographers also recommend logical breaks such as 0 in data classification so that negative values and positive values are clearly separated. There are four negative values, that is, decreases in population from 1990 to 1998, in the states theme (Connecticut, District of Columbia, North Dakota, and Rhode Island).


6.
Click on the scroll list button for Color Ramps in the Legend Editor. The list contains color schemes for mapping quantitative data. If you select Gray Monochromatic and click Apply, you should see a black-and-white U.S. map with gray symbols. To continue with the rest of this task, select Orange Monochromatic. If you have grouped the states with negative values into the first class (i.e., -13.8 to 0.0), it might be a good idea to change its color symbol. Double click the symbol for the first class to open the Symbol Palette. Press the Color Palette, and click on a color like green. You should see the green color symbol has become the symbol for the first class. If you click Apply, the U.S. map is redrawn with this new color scheme.


7.
If you still have the Color Palette on the screen, you can try the custom color option. Click on Custom on the Color Palette to open the Specify Color dialog, which is based on the HSV (Hue/Saturation/Value) color model. Each color dimension ranges in value from 0 to 255. You can make your own color by selecting a value for each color dimension. Click OK if you like a color in display. This color of your specification becomes a symbol in the color scheme. 


8.
Close the Legend Editor and the Color Palette. You are now ready to compose your map. Select Layout in the View menu.


9.
The Template Manager has five default templates. Click on Portrait and then OK. You should see the layout of the U.S. map with the title, legend, bar scale, and north arrow.


10.
Before manipulating the map elements in the layout, change the layout grid to a finer grid because the grid controls the alignment of the map elements. Select Properties from the Layout menu. In the Layout Properties dialog, set the horizontal and vertical grid spacing to 0.1''.


11.
You can manipulate an active graphic element in several ways. You can move it by dragging it to where you want it in the layout. You can reduce or enlarge it by dragging on its handles. Or you can select Size and Position from the Graphics menu and specify the height and/or width of the graphic element and its relative position in the layout, all in inches, in the Graphic Size and Position dialog. The only map element that is difficult for reduction or enlargement is the bar scale.


12.
If you cannot select a map element, you may need to use the Bring to Front button and Send to Back buttons.


13.
To add text such as your name on your map, press the Text tool and click the mouse at the location where you want to start the text string. In the Text Properties dialog, type the text, select the Horizontal Arrangement if it is needed, and then click OK. You can reduce, enlarge, or move the text after the initial placement.


14.
To add a neat line such as a map border to your map, press the Draw Point tool and select the rectangle symbol. Then place the cursor at the lower left corner of the intended neat line and drag the cursor to its upper right corner. The pull-down menu of the Draw Point tool contains other graphic devices that can be used for map design purposes, such as point, line, and circle. The default line width of the graphic device is usually too thin for its visual effect. You can change the line width by selecting Show Symbol Window from the Window menu and changing the width of Outline in the Fill Palette. 


15.
Several styles may be used for the N-arrow. To see the choices, select the N-arrow and double click on it to open a menu with different design options. Select a design and click OK.


16.
When you are ready to plot your map, select Print from the File menu. Or select Export and save your layout as a graphics file. 

Task 2: Graduated Symbol, Line Symbol, and Type Design

What you need: idlcity.shp, a theme showing the 10 largest cities in Idaho; idhwy.shp, a theme showing interstates, U.S., and state highways in Idaho; and idoutl.shp, an outline map of Idaho. 


Task 2 lets you experiment with type design, use the graduated symbol, and try the highway shield symbol in ArcView. The task also involves choice of color symbols and map design in general.


1.
Start ArcView, open a new view, and add idoutl.shp, idhwy.shp, and idlcity.shp to view. Select Properties from the View menu. Change the name of the view to a proper map title, change the Map Units to feet, and click OK. Select Properties from the Theme menu for each of the three themes, and change the name to an appropriate legend description.


2.
The only decision to be made about idoutl.shp is its color, the background color for the state, which should be contrasted with the point symbols for idlcity.shp and the highway symbol. Double-click idoutl.shp to invoke the Legend Editor and choose a color symbol for idoutl.shp.

3.
Double-click idhwy.shp to open the Legend Editor. Select Unique Value as the Legend Type, and Route_desc as the Value Field. You should see three default symbols assigned to interstate, state, and U.S. highways. Double-click the default symbol for the interstate to open the Pen Palette. You can change the line symbol (for example, to a double-line symbol) and its color. Repeat the same for state and U.S. highways.


4.
For the city theme, you will first show the city population using the graduated symbol. Double click idlcity.shp to open the Legend Editor. Select Graduated Symbol from the Legend Type pull-down menu. Select Population for the Classification Field. The default classification divides the cities into 
5 classes. For this map you can reduce the number of classes to 3 by clicking Classify and changing the number to 3. Also change the class breaks to 14302–30000, 30000–45000, and 45000–125659.


5.
Now work with Symbol and Size Range at the bottom of the Legend Editor. Symbol determines the symbol type, for example, open circle, filled circle, filled circle with outline, and so forth. Size Range determines the size variation of the graduated symbols. The default for Symbol is the filled circle. By double-clicking Symbol, you can change the symbol type using the Marker Palette. You can also use the Color Palette to change the color of the point symbol. Size Range is measured in point size, with 72 points to an inch. The default for Size Range is 4 to 12, a range with fairly small circle sizes on an 8.5-by-11-inch map. You can experiment with different size ranges and see which range works out best on your map. Remember that two cities are close to Boise; a large circle for Boise will cover up its neighboring cities. Click on Apply after you have chosen the symbol type and the size range.


6.
The next step is to label the cities. As explained in the chapter, you can label the cities interactively or by using the automatic labeling method. For this task, you will use the interactive method. (You will use the automatic labeling method in Task 3.) Make sure idlcity.shp is an active theme. Select Properties from the Theme menu to open the Theme Properties dialog, and click the Text Labels icon on the left. Choose city_name as the Label Field. Uncheck Scale Labels, meaning that you opt not to use scalable labels in your design. (The size of scalable labels will change as you zoom in and out of the view.) Click OK.


7.
Label cities in each class with a different type design. Select Show Symbol Window from the Window menu, and click on the Font Palette to open it. Choose the type variations, including typeface, size, and style (called form in the chapter), for the largest class. (It is a good idea to write down your type selection for reference later.) Click on the Label tool and click on a city that belongs to the largest class. You should see the name of the city appears with its handles. The handles indicate the name is now an active graphic element so that you can move it to where you see fit on the map. Do the same for other cities in the largest class. Then repeat the same process for the middle and smallest class. To achieve harmony in text design, stay with the same typeface for all three classes but vary type size and style.


8.
After labeling every city, you may still want to change the type design or move a name. You can do the following: click on the Pointer tool, click the name you want to work with (you should see the handles around it), and then move the name or change its type design. While depressing the Pointer tool, click outside the handles to make a name inactive.


9.
ArcView has a feature that allows you to add a label with a leader line. This feature is useful for labeling cities close together such as Boise-Nampa-Caldwell. Press the Label tool and select the Labeling with a Leader Line tool from the pull-down menu. Click on the city you want to have a leader line and drag the cursor to where you want to place the label. 


10.
ArcView also has a feature that allows you to label a road with a highway shield. You need to go through a couple of steps to use this feature. First, make sure idhwy.shp is active and choose Properties from the Theme menu. In the Theme Properties dialog, click the Text Labels icon, specify Minor1 (the field with the highway number) as the Label Field, select On for Alignment Relative to Line and Midway for Alignment Along Length, and uncheck Scale Labels. Click OK to dismiss the Theme Properties dialog. Next, select Text and Label Defaults from the Graphics menu. In the Default Setting dialog, choose the highway icon tool and set up the parameters for the tool. The parameters include two parts: one is the type design for the highway number, and the other is the shield symbol. Typically, you will set the size to be the same for the number and the symbol. 


11.
To label a highway, press the Label tool and select the icon tool you have set up in the previous step. Position and click the cursor on a highway where you want to place the highway shield. Repeat the same process for other highways in the same class. To label a different class of highways, repeat the previous step before labeling.


12.
Map design is an iterative process; therefore, you may have to repeat the above steps to create the map you really want. When you are satisfied with the look of your map in view, go to the layout to compose your map. The default legend in the layout consists of all theme descriptions as a graphic element, which often needs modification. For example, the legend includes a description of Idaho for the outline theme, which is really unnecessary. To delete the outline theme description, first make the legend an active graphic element and select Simplify from the Graphics menu to separate the legend into graphic elements. Then select the legend box and description for the outline theme and delete them. If you want to re-group the graphic elements into two legend parts—one for the cities and the other for the highways—you can use the Group function. First, depress the Shift key while dragging the cursor to make a frame around all the legend boxes and descriptions that belong to idlcity.shp. Then select Group from the Graphics menu. Now you can treat the idlcity.shp legend as a separate graphic element in manipulation. You can do the same for the idhwy.shp legend.


13.
When you are ready to plot your map, select Print from the File menu. Or you can select Export and save your layout as a graphics file.

Task 3: Text Labeling

What you need: charlie.shp, a theme showing Santa Creek and its tributaries in north Idaho.


Task 3 lets you try the automatic labeling method in ArcView. Although the method can label all features on a map and remove duplicate name, it requires adjustments on some individual labels and overlapped labels. Therefore, Task 3 also requires you to use the Spline Text tool.


1.
Start ArcView, open a new view, and add charlie.shp to view. Make the view window as large as possible. Select Properties from the Theme menu to open the Theme Properties dialog. In the dialog, click the Text Labels icon on the left, choose name as the Label Field, select Above for Alignment Relative to Line, and select Midway for Alignment along Length. Uncheck Scale Labels, and click OK to dismiss the dialog.


2.
The next step is to select type variations for the stream names. Select Show Symbol Window from the Window menu, and open the Font Palette. Use a serif type such as Times New Roman, a point size of 10, and the italic style.


3.
Select Auto-label from the Theme menu to open the Auto-label dialog. In the dialog, opt for Find Best Label Placement, check both Allow Overlapping Labels and Remove Duplicates, and click OK. 


4.
The view now has labels for the streams, but it has a couple of problems. Bob Cr. and Brown Cr. are in green, meaning that they are either overlapped with other labels or outside the map. The labeling of Pamas Cr. does not follow the course of the creek. 


5.
The labeling problems with Brown Cr. and Pamas Cr. are actually caused by the placement of Fagan Cr. Therefore the first step in correcting the problems is to re-label Fagan Cr. further upstream. Depress the Pointer tool and then select Fagan Cr. When the handles appear around the label, select Delete Graphics from the Edit menu to delete the label. Now re-label Fagan Cr. Press the Text tool and choose Spline Text from the pull-down menu. Position and click the cursor where you want the label to start. Click a couple of more points to make a curved line, and double click to exit. Type Fagan Cr. in the Spline Text Properties dialog and click OK. Fagan Cr. should now appear on the map. Repeat the same procedure if you are not satisfied with the re-labeling. You can use the same procedure to correct the labeling problems with Brown Cr. and Pamas Cr. For Bob Cr., you need to re-label it below the stream. Remember the names you have re-labeled are now individual graphic elements. The Remove Labels selection from the Theme menu will not remove them.

