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	Chapter 11

	Pre-Test/Post-Test Questions


Multiple choice:

1. How many stages are in the development lifecycle?

a. 3

b. 4

c. 5

d. 6

2. What is the maximum number of conditions you can use while performing conditional formatting?

a. 2

b. 3

c. 4

d. none of the above

3. Which Excel function returns the number of non-blank cells in a specified range?

a. COUNT

b. COUNTA

c. COUNTNON

d. none of the above

4. Which toolbar provides access to several helpful auditing tools?

a. Formula Auditing

b. Expression Auditing

c. Meta Auditing

d. Workbook Auditing

5. The acronym VBA stands for:

a. Virtual Business Application

b. Visual Basic for Applications

c. Visual Basic Application

d. none of the above

6. To ________ a worksheet means to review it for incorrect or suspect entries and formulas.

a. share

b. validate

c. audit

d. customize

e. none of the above

7. There are _______________ docking areas for manipulating toolbars.
a. 2

b. 3

c. 4

d. 5

e. none of the above

8. By default, Excel keeps how many days of change history stored in a shared workbook?

a. 14

b. 21

c. 28

d. 30

9. Which Excel function returns a usable cell reference from a text string?

a. CELL_STRING

b. CONVERT_STRING

c. STRING2REFERECE

d. none of the above

10. Searching for cells that are referred to in a specific formula is called:

a. auditing

b. tracing

c. tracing precedents

d. tracing dependents

11. What is the name given to a special type of macro that executes without your interaction?

a. self-executing macro

b. automatic macro

c. automacro

d. none of the above

12. A toolbar in Excel can contain which of the following?

a. menus

b. buttons

c. drop-down list boxes

d. all of the above

e. none of the above

True / False:

13.  You can delete a worksheet in a shared workbook.

14. By default, Excel 2003 keeps 45 days of change history stored in a shared workbook.

15. While building conditional formatting rules, you can preview the format which will be applied if the conditions are met.

16. You can obtain additional smart tags by visiting Microsoft’s Web site.

17.  During an audit, green lines, called tracer arrows, are displayed on the worksheet showing the cell relationships.

18. The Personal Macro Workbook is located in the Windows folder and is managed privately by Excel.

19. While customizing a Toolbar, removing buttons that you do not use and replacing them with frequently used commands can increase your productivity.

20. You can not apply conditional formats in a shared workbook.

21. In building data validation rules, you can not specify acceptable entries in a worksheet list.

22. The Watch Window allows you to display the values and formulas stored in one or more cells.

23. A macro virus is a special type of virus that lives inside a worksheet cell.

24.  A VBA project file can contain multiple modules, and it is always associated with a specific workbook or with the Personal Macro Workbook.

25. There may be circumstances in which creating a new toolbar is easier than modifying the existing ones.

Fill-in-the-blanks:

26. It is important to note that the original author of a workbook establishes its _____ _____ and then stores it on a network server that is accessible to a specific group of users.

27. Excel 2003’s _____ ______ feature allows you to change a cell’s appearance based on its value or on a particular condition.

28. Microsoft Office 2003’s _____ _____ enable you to perform tasks, suck as retrieving information from the Internet that would normally require multiple actions to execute.

29. The _____ functions enable you to test for the existence of labels, values, and errors in a worksheet.

30. Microsoft Office 2003 provides personalized menus and _____ for dynamically presenting the commands you use most often.

31.  The _______________ is an excellent tool for quickly storing a sequence of instructions that can be played back immediately.

32. The development life cycle stages are: Analyze, Design, Develop, _______________ and Evaluate.

33. When tracking changes in a shared notebook, a cell _____ is used to signify that a cell has been modified by you or another user.

34. A _____ cell range is one that grows and shrinks automatically as you enter and remove data.

35. When examining the color-coded triangles which appear in cells to indicate that errors may be present, a green triangle warns you of a possible _____ error.

36. Excel allows you to store and play back keystrokes and commands.  These stored instructions are called _____.

37. Use the _____ dialog box to create a new toolbar in Excel.

38. A _______________ is a program that is created with the intention of doing harm to your computer.

	Chapter 11

	Pre-Test/Post-Test Answer Key


Multiple choice:


1. C (11.1.1:11-3)

2. B (11.2.1:11-15)

3. B (11.2.4:11-26)

4. A (11.3.2:11-37)

5. B (11.4.1:11-49)

6. C (11.3:11-29)

7. B (11.5.2:11-66)

8. D (11.1.2:11-7)

9. D (11.2.4:11-26)

10. C (11.3.3:11-40)

11. C (11.4.1:11-53)

12. D (11.5.2:11-66)

True / False:

13. F (11.1.1:11-4)

14. F (11.1.2:11-7)

15. T (11.2.1:11-16)

16. T (11.3.1:11-36)

17. F (11.3.3:11-40)

18. F (11.4.1:11-50)

19. T (11.5.3: 11:67

20. T (11.1.1:11-4)

21. F (11.2.2:11-20)

22. T (11.3.4:11-43)

23. F (11.4.3:11-55)

24. T (11.4.4:11-58)

25. T (11.5.4:11-71)

Fill-in-the-blanks

26. shared properties (11.1.1:11-4)

27. conditional formatting (11.2.1:11-15)

28. smart tags (11.3.1:11-30)

29. IS (11.3.5:11-46)

30. toolbars (11.5.1:11-63)

31. Macro Recorder (11.4.4: 11-56)

32. Implement (11.1: 11-3)

33. indicator (11.1.2:11-8)

34. dynamic (11.2.4:11-26)

35. formula (11.3.1:11-30)

36. macros (11.4:11-49)

37. Customize (11.5.4:11-71)

38. virus (11.4.3: 11:54)
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	Chapter 11
	Developing Applications Using Excel


Overview

Chapter 11 further expands the capabilities of Excel beyond those of just a spreadsheet for a single user.  The chapter starts with a discussion of the creation and the management of shared workbooks, allowing multiple users to simultaneously access a workbook at a time.  Chapter 11 then proceeds to cover the following features and topics: tracking and reviewing changes to workbooks, the validation of worksheet data via conditional formatting and validation rules, formula auditing, the creation and management of macros, as well as the customization of Excel’s menu and toolbars.

Tips and Teaching Strategies

Use caution when covering the use of shared workbooks.  To properly create a shared workbook, one must utilize shared network locations.  Depending on your lab configuration, you may not have shared network locations (not all network administrators like to set them up for security reasons!).  In addition, stress to the students that they likely don’t have shared network locations (or a network for that matter) in their dorms or at home.

Section 11.1 – Planning a Workbook Application

Section 11.1 moves the users toward spreadsheets as a single-user application and toward a multi-user application.  This is achieved by the discussion of the creation and management of shared workbooks, whereby multiple users are allowed to simultaneously change the workbook.  In support of multiple users, the section also covers how to track changes to a workbook and how to merge revisions of a workbook into one complete workbook.

Section 11.1.1 – Creating a Shared Workbook

Concept:
Creating shared workbooks

Method:
Excel workbooks can be shared simultaneously among users, presuming that they share the workbook file from a common network location.  To enable a workbook for sharing, choose the Share Workbook menu item from the Tools menu.  The Share Workbook dialog box will appear, allowing you to configure the sharing properties.

Click the Editing tab of the dialog box and select the Allow changes by more than one user at the same time check box.  This enables the simultaneous access to the workbook by multiple users.  Next, click the Advanced tab of the Share Workbook dialog box to configure additional settings.  Such settings include how often to display changes to the workbook, how long changes are tracked for, and how data conflicts are resolved within Excel.  Click the OK button to complete the configuration of the settings.  Be sure to save the workbook file to a network location so that other users may now access and modify the workbook.

Notes:
None.

Section 11.1.2 – Tracking Changes to a Workbook

Concept:
Enabling change tracking and displaying changes

Method:
Changes to workbooks can be tracked and displayed easily in Excel.  To do so, choose the Track Changes menu item from the Tools menu and then choose the Highlight Changes menu item from the menu that appears.

Next, in the Highlight Changes dialog box that appears, select the Track changes while editing check box and specify which types of changes are to be highlighted and how they are to be displayed.  Finally, click the OK button to enable and display the tracked changes. 

Notes:
By default, Excel 2003 keeps 30 days of change history stored in a shared workbook.  It also keeps track of all content changes that are made, including when they are made and by whom.
Concept:
Reviewing highlighted changes

Method:
To review highlighted changes, choose the Track Changes menu item from the Tools menu, and choose the Accept or Reject Changes menu item from the menu that appears.  The Select Changes to Accept or Reject dialog box will then be displayed, permitting the user to specify which types of changes to review (review by when changes were made, by who made the changes, and what range of cells to concentrate on).

One by one, each change will be listed (according to the criteria previously specified), detailing what changed, who make the change, and when the change occurred.  Changes can be accepted by clicking the Accept button (all changes can be accepted by clicking the Accept all button).  Changes may also be rejected individually by clicking the Reject button (reject all changes by clicking the Reject all button).

Notes:
None.

Section 11.1.3 – Merging Workbook Revisions

Concept:
Merging workbook revisions

Method:
To merge revisions from workbooks which are not shared in a simultaneous manner (as described above), open the workbook where all changes will be merged into.  Then, choose the Compare and Merge Workbooks menu item from the Tools menu.

The Select Files to Merge into Current Workbook dialog box will appear, allowing you to select which other workbooks to merge into the one currently displayed.  Select the desired workbooks and click the OK button.  Finally, to accept or reject the changes into the current workbook, use the Reviewing highlighted changes methodology described above to accept or reject the changes to the selected workbooks.

Notes:
None.

Section 11.2 – Validating Data

Section 11.2 covers various techniques which can be used to validate data input to cells.  The topics included in this section are the application of conditional formatting, applying and removing data validation rules, locating and copying data validation rules, and using the INDIRECT and COUNTA functions to build dynamic cell ranges (which come in quite handy with data validation rules).

Section 11.2.1 – Applying Conditional Formatting

Concept:
Applying conditional formatting

Method:
To apply conditional formatting on a range of cells, select the desired cells and choose the Conditional Formatting menu item from the Format menu.  Then, in the Conditional Formatting dialog box that is displayed, use the Condition area(s) to define each condition to be verified and the format to apply if the condition is met.

Click the Add >> button to add additional conditional formatting settings to the selected range of cells.  Click the OK button to apply the conditional formatting settings to the selected range.

Notes:
Conditional formatting can not be performed on a shared workbook.  No more than three conditions may be set for a given range of cells.

Section 11.2.2 – Applying and Removing Validation Rules

Concept:
Applying data validation

Method:
Data validation constraints can be applied to a cell or range of cells to ensure data values adhere to a range of inputs, are members of a list, or are not wider than a given length.  To apply data validation rules, select the cell or range of cells to apply the validation to, and then choose the Validation menu item from the Data menu.

The Data Validation dialog box will be displayed, permitting the input of the validation rules for the selected cell(s).  The Settings tab is used to define the validation rules.  The Input Message tab permits the building of a custom screen tip displayed when the cell(s) are selected.  Use the Error Alert tab to define a custom error dialog box to display to users when the data is not accepted by the validation rules.  Click the OK button to set the validation rules and dismiss the Data Validation dialog box. 

Notes:
None.

Concept:
Removing a validation rule

Method:
To remove an existing validation rule, select the cell range containing the desired validation and choose the Validation menu item from the Data menu.  The Data Validation dialog box will be displayed.  Click the Clear All button to remove the validation criteria and then click the OK button to dismiss the dialog box.

Notes:
None.

Section 11.2.3 – Finding and Copying Validation Rules

Concept:
Selecting cells with data validation rules

Method:
To locate and select cells which contain validation rules in them, choose the Go To menu item from the Edit menu.  Click the Special… button in the Go To dialog box that appears.  Next, select the Data validation option button and the All option button (beneath the Data validation option).  Click the OK button to remove the dialog box.  Each cell which contains a data validation rule will now be selected. 

Notes:
None.

Concept:
Copy and pasting data validation rules

Method:
To copy a data validation rule from one cell to another (or to a range of cells), select the source data cell which contains the data validation.  Then, click the Copy button on the Standard toolbar and then select the destination cell(s) you wish to copy the data validation rules to.  Choose the Paste Special menu item from the Edit menu and select the Validation option in the Paste Special dialog box that appears.  Click the OK button to complete the paste operation.

Notes:
None.

Section 11.2.4 – Using Dynamic Ranges for Data Validation

Concept:
Building dynamic ranges using the INDIRECT and COUNTA functions

Method:
The INDIRECT and COUNTA functions can be used jointly to build dynamic cell ranges (for use in data validation and other areas).  First, we shall explain the functions individually, and then discuss how they can be used jointly.

· COUNTA function – returns the number of non-blank cells within a specified range.  Syntax: =COUNTA(range), where range is the range of cells to examine.

· INDIRECT function – returns a usable cell reference from a text string.  Syntax: =INDIRECT(string), returns a cell reference from the provided string.

By joining the two functions together, we can obtain a dynamic cell range, usable in other functions or in Excel 2003 features requiring cell ranges.  For example, the following formula returns a usable cell range of cells from the Employees worksheet comprised of the range of non-blank cells of the C column starting at cell $C2:

=indirect(“Employees!$C2:$C”&counta(Employees!$C:$C))

Notes:
None.

Section 11.3 – Auditing a Worksheet

This section covers the features in Excel 2003 which assist in the discovery of errors.  The topics and features covered by Section 11.3 include cell indicators, option buttons, smart tags, using the various components of the Formula Auditing toolbar to locate and display invalid data, precedent and dependent cells, the Trace Error display, Watch Window dialog box, and the use of the IS family of functions in Excel 2003. 

Section 11.3.1 – Identifying Cell Indicators, Option Buttons, and Smart Tags

Concept:
Reacting to a triangle cell indicator

Method:
When a small triangle appears in the lower-right corner of a cell, you can position the mouse pointer over the cell and an options button will be displayed.  Depending on the type of data or formula in the cell, the options button can be one of a variety of types.  Click the options button which has appeared and choose the desired command from the menu that appears.

Notes:
None.

Concept:
Enabling Smart Tags

Method:
To enable the displaying of Excel’s Smart Tags, choose the AutoCorrect Options menu item from the Tools menu.  Then, click the Smart Tags tab in the AutoCorrect dialog box which has appeared.  Next, select the Label data with smart tags check box and select what type of data to recognize from the Recognizers list box.  Finally, click the OK button to finish.

Notes:
None.

Section 11.3.2 – Locating Invalid Data Using the Formula Auditing Toolbar

Concept:
Highlighting invalid data using the Formula Auditing Toolbar 

Method:
Data in cells which are considered invalid by the data validation rules for a cell can be highlighted by using the Formal Auditing Toolbar.  To highlight invalid data with a circle, first display the toolbar by choosing the Formula Auditing menu item from the Tools menu, and then choose the Show Formula Auditing Toolbar menu item from the menu that appears.

To highlight the invalid data, click the Circle Invalid Data button on the toolbar that has just appeared.  The highlighting circles can be cleared by clicking the Clear Validation Circles button found on the toolbar as well.

Notes:
None.

Section 11.3.3 – Tracing Precedents and Dependants 

Concept:
Tracing Precedents

Method:
You can display graphical arrows from cells referred to in a given formula (precedents) to the cell containing the formula.  To display these precedent arrows, select the cell containing the desired formula and click the Trace Precedents button on the Formula Auditing toolbar.  Once clicked, the arrows will overlay the values of the cells and point to the designated formula.

Notes:
None.

Concept:
Tracing Dependents 

Method:
To display graphical arrows from a selected cell (dependent cell) to the cells which depend on the selected cell, select the desired cell and click the Trace Dependents button on the Formula Auditing toolbar.  Once clicked, the arrows will overlay the value of the cell and point to any other cells which are dependent on the selected cell.

Notes:
None.

Concept:
Removing precedent and dependent arrows

Method:
To remove either precedent or dependent arrows from a worksheet, click the Remove Precedent Arrows, Remove Dependent Arrows, or Remove All Arrows buttons on the Formula Auditing toolbar.

Notes:
None.

Section 11.3.4 – Locating Errors in Formulas 

Concept:
Using the Trace Error button

Method:
You can use the Trace Error button on the Formula Auditing toolbar to display dependencies on a formula which results in an error.  To do so, select an error which results in an error and click the Trace Error button. 

Notes:
None.

Concept:
Evaluating a formula

Method:
Use the Evaluate Formula button to interactively evaluate an expression in a cell in a step-by-step manner.  To use this feature, select any cell which contains an expression or formula and click the Evaluate Formula button on the Formula Auditing toolbar.

Then, click the Evaluate button to calculate that portion of the expression or formula which is underlined in the Evaluation area of the Evaluate Formula dialog box that has appeared.  By continuing to click the Evaluate button, you can watch the expression be solved, spotting potential errors as they arise.

Notes:
None.

Concept:
Using the Watch Window

Method:
Excel’s Watch Window can be used to display the value and formula for a range of cells.  Changes made to cells added to the Watch Window will be reflected in the watch window, thereby allowing the user to monitor changes in the spreadsheet in a compact area.

To display the Watch Window, click the Show Watch Window button on the Formula Auditing toolbar.  Then, in the Watch Window dialog box that appears, click the Add Watch… button and provide a range of cells to add to the Watch Window.  Click the Add button and the range of cells will be added to the Watch Window.

Notes:
None.

Section 11.3.5 – Preventing Calculation Errors 

Concept:
Using the IS family of functions

Method:
By incorporating one or more of the IS family of functions (ISBLANK, ISERROR, etc.) into expressions, you can prevent calculation errors within your worksheets.  Generally used with the IF conditional statements, IS functions will permit you to check the critical portions of expressions where invalid data values might create expression errors (such as divide by zero errors).  The functions in this family are as follows:

· ISBLANK function – returns a true value if the specified cell reference is empty.  Syntax: =ISBLANK(ref), where ref is a reference to a cell in the workbook.

· ISERROR function – returns a true value if the specified cell reference refers to any error value (such as #N/A, #REF!, #VALUE!, #NULL!, etc.).  Syntax: = ISERROR (ref), where ref is a reference to a cell in the workbook.

· ISNUMBER function – returns a true value if the specified cell reference refers to a number.  Syntax: = ISNUMBER (ref), where ref is a reference to a cell in the workbook.

· ISTEXT function – returns a true value if the specified cell reference refers to text.  Syntax: = ISTEXT (ref), where ref is a reference to a cell in the workbook.

Notes:
None.

Section 11.4 – Automating a Workbook

Section 11.4 covers the basics of simple workbook automation tasks that any user can take advantage of.  The features and tasks covered by this section include the development, editing, execution, and printing of macros.  Macros are stored sequences of commands (comprised of Visual Basic programming code) which can be created by either the recording of user actions or programming the source code directly.  Section 11.4 also touches on the setting of security restrictions for macros, in an effort to prevent macro viruses (which have become an increasing virus problem on computers).

Section 11.4.1 – Recording a Macro

Concept:
Recording a new macro

Method:
To record a new macro in Excel, choose the Macro menu item from the Tools menu, and then choose the Record New Macro menu item from the menu that appears.  The Record New Macro dialog box will appear, permitting the user to enter a name for the macro, shortcut key (if desired), and a description for the macro about to be created.

Next, select a location to store the macro from the Store macro in: drop-down list box.  Click the OK button and begin performing the steps you wish to have recorded as the macro.  When you have completed the steps, click the Stop button on the Stop Recording toolbar which appeared when you clicked the OK button.

Notes:
None.

Section 11.4.2 – Playing Back a Macro

Concept:
Playing back a recorded macro 

Method:
To play back a recorded macro, open the Macro dialog box by choosing the Macros… menu item from the Tools menu, and then by choosing the Macros menu item from the sub-menu that appears.

Select the desired macro to play back and click the Run button in the Macro dialog box.  The selected macro will then be executed.

Notes:
You can also double-click the macro’s name in the list box displaying all available macros, to execute the desired macro.

Section 11.4.3 – Protecting Yourself from Macro Viruses 

Concept:
Setting a macro security level 

Method:
You can specify a macro security level to help prevent malicious macros from destroying your work.  This feature comes in especially handy when opening an Excel file from an unknown source, especially if you suspect malicious intent.  To specify a security level (High, Medium, or Low), open the Security dialog box by choosing the Macro menu item from the Tools menu, and then choose the Security menu item from the sub-menu that appears.

Select the desired security level from the options presented on the Security Level tab of the dialog box, and click the OK button to enable the settings.

Notes:
None.

Section 11.4.4 – Editing a Recorded Macro 

Concept:
Editing macros via the Visual Basic Editor

Method:
You can edit the source code that comprises a recorded macro by using the Visual Basic Editor which is embedded in Excel.  To open the editor, first open the Macro dialog box as described in Section 11.4.2.  Then, select the desired macro to edit from the list box and click the Edit button.  The Visual Basic Editor will appear, and you can then make your edits to the source code within the editor.

Once you have completed your edits, choose the Close and Return to Microsoft Excel menu item from the Visual Basic Editor’s File menu.  The macro will be resaved and the dialog box will be closed, returning the user to the Excel worksheet environment.

Notes:
A shortcut for opening the Macro dialog box is to type Alt+F8.

Section 11.4.5 –Printing Your Macros

Concept:
Printing a macro’s source code

Method:
Users can print the source code that comprises an existing macro.  To do so, open the desired macro in the Visual Basic Editor (instructions for doing so are found in Section 11.4.4 above).  Once the macro has been opened in this fashion, choose the Print menu item from the File menu.  The Print dialog box will appear.

Select the Current Module option button from the Range area, if it is not already selected.  Also, ensure that the Code check box in the Print What area is checked.  Finally, click the OK button to send the selected macro’s source code to the printer.

Notes:
None.

Section 11.5 – Customizing Menus and Toolbars
Section 11.5’s content provides coverage of the use and customization of menus and toolbars.  Topics covered by this section include how to modify the Excel 2003 menu bar, how to manipulate (float, dock, hide, and display) toolbars, customize existing toolbars, and create new toolbars from scratch.

Section 11.5.1 – Modifying the Menu Bar

Concept:
Modifying the commands in an existing menu bar

Method:
By using the customization tools in Excel you can alter the content of the menu bar and menus that exist.  To modify the menu bar, choose the Customize menu item from the Tools menu.  In the Customize dialog box that appears, click the Commands tab.

Next, select a category from the Categories list box and drag a command from the Commands list box to the desired location on the menu bar.  When you release the mouse, the dragged command will be added to the specified location on the menu bar or to the location in a menu.  Click the Close button on the dialog box to complete the changes to the menu bar and to dismiss the dialog box.

Notes:
None.

Section 11.5.2 – Manipulating Toolbars

Concept:
Floating a toolbar

Method:
To float a toolbar, drag the toolbar by its move handle away from its docked position.  Upon releasing the toolbar, the toolbar will float over the application window in a window or dialog box of its own.

Notes:
None.

Concept:
Docking a toolbar

Method:
To dock a toolbar, drag the toolbar by its Title bar to one of the walls of the application window.  Once near a wall, the toolbar will attach itself to the wall.

Notes:
There are four docking areas for toolbars, alongside the top and bottom horizontal walls and the left and right vertical walls.

Concept:
Hiding or displaying a toolbar

Method:
To hide or display a toolbar, choose the Toolbars menu item from the View menu.  Then, select the desired toolbar to hide or display by selecting the toolbar from the menu list that appears.

Notes:
None.

Section 11.5.3 – Customizing a Toolbar 

Concept:
Customizing existing toolbars

Method:
To add, remove, or change the order of commands on a toolbar, display the Customize dialog box as described in Section 11.5.1.  Then perform one or more of the following steps to customize the toolbars further.

· Add a command to a toolbar – click the Commands tab of the Customize dialog box and drag a command to a toolbar to add the command to the desired toolbar.

· Removing a command from a toolbar – drag the desired command away from the toolbar and into the application window.  When you release the mouse, the command will be removed from the desired toolbar.

· Changing the order of commands on a toolbar – drag command icons on the toolbar to a different position.  A vertical line (I-beam) will indicate where the icon will be placed when the mouse is released.

Notes:
None.

Section 11.5.4 – Creating a New Toolbar 

Concept:
Creating a new toolbar

Method:
To create a new (blank) toolbar, open the Customize dialog box as described in Section 11.5.1.  Then, click the Toolbars tab and click the New command button in the dialog box that has appeared.

Type a name for the new toolbar in the Toolbar name: text area and click the OK button.  The toolbar will then be added to the list of toolbars in the Customize dialog box and displayed in the application window.  You can now add commands to the toolbar, as you did in Section 11.5.3.

Notes:
None.

Concept:
Assigning a macro to a toolbar button

Method:
To assign a macro to a toolbar button, open the Customize dialog box as described in Section 11.5.1, and then right-click the desired toolbar button.  Next, choose the Assign Macro menu item from the menu that has appeared.  Select the desired macro to apply to the button from the list of macros, and click the OK button.  The macro has not been assigned to the specified button.

Notes:
None
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Chapter 11 
Answers to End-Of-Chapter Review Questions

Short Answer

1. Name the five stages in the workbook development life cycle. The five stages in the workbook development life cycle are analyze, design, develop, implement, and evaluate.
2.
What would you do to prepare a workbook for placement onto a workgroup’s network server? To ensure that a workbook can be shared on network server, choose Tools ( Share Workbook command and then select the Allow changes by more than one user… check box. On the Advanced tab, you can specify whether to maintain a history and when to update changes.
3.
How does conditional formatting complement data validation? Conditional formatting complements data validation by formatting cells based on the user's input. Therefore, conditional formatting provides immediate visual feedback if a user inputs incorrect data.
4.
How could you determine whether existing values in a worksheet conform to newly specified data validation rules? You can use the Auditing toolbar and the Circle Invalid Data button ([image: image1.png]


) to circle the values that do not comply with the data validation rules. 
5.
What is a macro? Where are they stored? A macro is a sequence of stored commands and keystrokes. Macros can be stored with a workbook or in a special workbook file called the “Personal Macro Workbook.” Macros stored in the Personal Macro Workbook are available for use in any workbook that you create.
6.
What is an automacro? Provide an example. An automacro is a macro that is executed automatically without user interaction. Most commonly, these macros are set to activate when a workbook is opened, saved, or closed. One example might be a workbook that displays a welcome screen (worksheet) or a table of contents when it is first opened.
7.
Why might you want to edit an existing macro? You may want to edit an existing macro to change the information that is entered or to correct a few mistakenly selected commands. Or, perhaps you want to expand a macro with a few additional steps. It is often easier to make a few minor corrections in an existing macro than to record the entire macro procedure again. 
8.
How do macros and macro viruses differ? A macro is a helpful set of instructions designed to automate time-consuming tasks. A macro virus is a program designed to harm your workbook or computer.
9.
How do you protect yourself against macro viruses? First and foremost, use anti-virus software. You can also use the Tools ( Macro ( Security command to specify a security level for dealing with macros stored in workbooks. With medium security enabled, you can enable or disable a workbook’s macros when opening the file. 

10.
How do you assign a macro to a toolbar button? After adding a custom button to a toolbar, right-click the button and choose the Assign Macro command. Double-click the desired macro in the dialog box that is displayed. 

True/False

	1.
	F
	6.
	T

	2.
	T
	7.
	T

	3.
	F
	8.
	T

	4.
	F
	9.
	F

	5.
	F
	10.
	F


Multiple-Choice

	1.
	c
	6.
	c

	2.
	b
	7.
	d

	3.
	c
	8.
	b

	4.
	d
	9.
	d

	5.
	a
	10.
	b
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