ArcGIS 9.3 Fix for Chang’s 4th edition
The following fixes are for ArcGIS 9.3 users, who are using Chang’s 4th edition. The fixes, which are highlighted, are organized by chapter, task, and step. For geocoding exercises in Chapter 17 (Task 1 and Challenge Task), use the new data sets that are provided at the website. ArcGIS 9.3 uses a geocoding engine that is different from ArcGIS 9.2.  
Chapter 1
Task 2: Introduction to ArcMap
8. Next classify emidalat into the elevation zones of <900, 900–1000, 1000–1100, 1100–1200, 1200–1300, and >1300 meters. Right-click emidalat, and select Properties. Click the Symbology tab. Click Classified in the Show frame. Click Yes in the Compute Unique Values dialog. Change the number of classes to 6, and click the Classify button…
Chapter 2: None

Chapter 3
Task 1: Examine the Data File Structure of Coverage and Shapefile
1. Start ArcCatalog, and make connection to the Chapter 3 database. Click the Show/Hide ArcToolbox Window button to open the ArcToolbox window. Double-click the Import From Interchange File tool in the Coverage Tools/Conversion/To Coverage toolset. (The Coverage Tools require an ArcInfo license.) Navigate to the Chapter 3 database and select land.e00 for the input interchange file. Specify land for the output dataset. Click OK to execute the conversion. An alternative is to use the Import from Interchange File tool of ArcView 8x Tools, available in ArcCatalog’s View menu.

Chapter 4
Task 1: Create Geodatabase, Feature Dataset, and Feature Class
2. Next create a new feature dataset. Right-click Task1.mdb, point to New, and select Feature Dataset. In the next dialog, enter Area 1 for the name. Then import the coordinate system of stream.shp to be the feature dataset’s coordinate system. Click Finish to exit the dialog.
Chapter 5
Task 1: View USGS DEM Data
1. Start ArcCatalog and connect to the Chapter 5 database. Click Show/Hide ArcToolbox Windows to open the ArcToolbox window in ArcCatalog. Double-click the Import From SDTS tool in the Coverage Tools/Conversion/To Coverage toolset. (The Coverage Tools require an ArcInfo license.) An alternative is to use the SDTS Raster to Grid tool of ArcView 8x Tools, available in ArcCatalog’s View menu. (To use the SDTS Raster to Grid tool, it requires changing the output grid name from Menan-Buttes to menanbuttes for the rest of Task 1.)
Chapter 6
Task 1: Download and Process DEM and DLG from the Internet

What you need: access to the Internet, a unzip tool, ArcInfo license, and ArcInfo Workstation.
Task 4: Online Connection to the U.S. Fish and Wildlife Service’s National Wetland Inventory

2. This step adds and queries Hawaii’s wetland data in ArcMap. Launch ArcMap, if necessary. Rename the data frame Task 4. Click the Add Data button, and add USFWS_WMS_HI_Wetlands to Task 4. Expand the added data in the table of contents. There are two layers in the folder: HI Wetland Polygons, and HI Available Wetland Data. 

4. This step adds shaded relief to the map. Click File in ArcMap, and select Add Data From Resource Center. Click on World Shaded Relief in the next dialog. Move Web Map Service USFWS_WMS_HI_Wetlands to the top of the table of contents. You can now see wetland polygons with a shaded-relief background.
Chapter 7

Task 1: Georeference and Rectify a Scanned map

4. This step is to update the coordinate values of the four control points. Click the View Link Table tool on the Georeferencing toolbar. The link table lists the four control points at the top with their X Source, Y Source, X Map, Y Map, and Residual values. The X Source and Y Source values are the coordinates on the scanned image. The X Map and Y Map values are the UTM coordinates to be entered. The link table offers Auto Adjust, the Transformation method, and the Total RMS Error. Notice that the transformation method is 1st Order Polynomial (i.e., affine transformation). Click the first record, and enter 575672.2771 and 5233212.6163 for its X Map and Y Map values respectively. (Ignore the warning message about the control points being collinear or not well distributed.) Enter the X Map and Y Map values for the other three records.
Chapter 8

Task 3: Use Topology Rule to Fix Dangles

Q6. What is the rule description for “Must Not Have Pseudonodes”?
Task 5: Perform Edgematching

(Substitute Steps 4-7 with the following Steps 4-6)
4. You are ready for edgematching. Zoom to the top area between hoytmtn and mrblemtn so that you can see the first pair of unmatched soil lines. Click the Edge Match tool on the Spatial Adjustment toolbar, and drag a box around the gap. A link should now connect the two end points: the link is shown as an arrow and the end points as squares. 

5. The Edge Match tool can work with more than one link at a time. Click the Full Extent button in ArcMap. Make sure that the Edge Match tool is activated. Drag a box so that the box covers the remaining unmatched soil lines and the bottom border. Click the View Link Table tool on the Spatial Adjustment toolbar. The Link Table should have 9 records (8 new links plus the one from Step 4). Each record shows the shift of a vertex in hoytmtn to its new location through adjustment.   

6. If all links are set, select Adjust from the Spatial Adjustment dropdown menu. At this point, the edgematching operation is complete. Select Stop Editing from the Editor menu and save the edits.
Chapter 9

Task 2: Join Tables in ArcMap
2. Open the attribute table of wp and wpdata. The field ID is in both tables and will be used as the field in joining the tables. 
3. Now join wpdata to the attribute table of wp. Right-click wp, point to Joins and Relates, and select Join. (Another option, new in ArcGIS 9.3, is to select Join from the Options dropdown menu in the wp attribute table.) At the top of the Join Data dialog, opt to join attributes from a table. Then, select ID in the first dropdown list, wpdata in the second list, and ID in the third list. Click OK to join the tables. Open the attribute table of wp to see the expanded table.
Task 4: Create New Attribute by Data Classification

2. Open wpdata in Tasks 3-6. ELEVZONE appears in wpdata with 0s. Click the Options dropdown arrow and choose Select By Attributes. Make sure that the selection method is to create a new selection. Enter the following SQL statement in the expression box: “ELEV” > 0 AND “ELEV” <= 40. Click Apply. Click Selected at the bottom of the table so that only selected records are shown. These selected records fall within the first class of ELEVZONE. Right-click the field ELEVZONE, and select Field Calculator. Click Yes to proceed in the message box. Enter 1 in the expression box of the Field Calculator dialog, and click OK. The selected records in wpdata are now populated with the value of 1, meaning that they all fall within class 1.

Task 5: Use Advanced Method for Attribute Data Classification
What you need: wpdata.dbf.

You have classified ELEVZONE in wpdata.dbf by repeating the procedure of selecting a data subset and calculating the class value in Task 4. Task 5 shows how to use a Visual Basic script and the advanced option to calculate the ELEVZONE values all at once. If Task 5 fails to run in ArcGIS 9.3, ESRI recommends that a repair is run on the ArcGIS Desktop install (http://support.esri.com/index.cfm?fa=knowledgebase.techarticles.articleShow&d=25207). To run a repair: Navigate to Start > Settings > Control Panel > Add or Remove Programs. Select ArcGIS Desktop and click the Change button. When prompted, select the Repair option.
1. Open wpdata in Tasks 3-6. ELEVZONE should appear in the table with values calculated in Task 4. If necessary, clear selected records in wpdata by selecting Clear Selection from Options’ dropdown menu and click All to show all records. Right-click ELEVZONE and select Field Calculator. Click Yes to proceed in the message box.

Chapter 10
Task 3: Label Streams

1. Launch ArcMap. Rename the data frame Task 3, and add charlie.shp to Task 3. Select Page and Print Setup from the File menu. Uncheck the box for Use Printer Page Settings. Enter 5 (inches) for Width and 5 (inches) for Height. Click OK to dismiss the Page and Print Setup dialog.
Chapter 11

Task 1: Select Feature by Location
5. Right-click snowsite, point to Data, and select Export Data. Export the selected features and save them into an output shapefile named svstations. Now you will graph the elevation (ELEV) and maximum snow water equivalent (SWE-MAX) of the selected snow courses. Click the Tools menu in ArcMap, point to Graphs, and select Create. In the first panel of the Create Graph Wizard, select Scatter Plot for the graph type, svstations for the layer/table, ELEV for the Y field, and SWE_MAX for the X field. Click Next. In the second panel, enter Elev-SweMax for the title. Click Finish. A scatter plot of ELEV against SWE_MAX appears.

Task 3: Query Attribute Data from a Joint Attribute Table
2. wpdata is now joined to the wp attribute table. Open the attribute table of wp. The table now has two sets of attributes. Click the Options dropdown arrow and choose Select by Attributes…
5. …You can bookmark the zoom-in area for future reference. Click the Bookmarks menu, and select Create. Enter protect for the Bookmark Name. To view the zoom-in area next time, click the Bookmarks menu and select protect.
Chapter 12
APPLICATIONS: VECTOR DATA ANALYSIS 

This applications section has four tasks. Task 1 covers the basic tools of vector data analysis including Buffer, Overlay, and Select. Because ArcGIS does not automatically update the area and perimeter values of an overlay output in shapefile format, Task 1 also uses the Calculate Geometry tool to calculate the area and perimeter values… 

Task 1: Perform Buffering and Overlay

(Substitute Steps 7-8 with the following instructions)
7. Right-click Shape_Area in the attribute table of sites and select Calculate Geometry. Click Yes to do a calculate outside of an edit session. In the Calculate Geometry dialog, select Area for the property and Square Meters for units. Click OK. Shape_Area is now populated with correct area values.

8. Right-click Shape_Leng and select Calculate Geometry. Click Yes in the next dialog. In the Calculate Geometry dialog, select Perimeter for the property and Meters for units. Click OK. Shape_Leng is now populated with correct perimeter values.

Task 4: Compute General and Local G-statistics

(Substitute Steps 5-7 with the following instructions)
5. Next you will run the local G-statistic. Double-click the Hot Spot Analysis (Getis-Ord Gi*) tool in the Spatial Statistics Tools/Mapping Clusters toolset. Select adabg00 for the input feature class, select Latino for the input field, and specify a distance band of 5000 (meters). Click OK to execute the command. 

6. Open the attribute table of adabg00_HotSpots. The table is the same as adabg00 but has the added fields of GiZScore and GiPValue, storing the Z score and the probability value of the local G-statistic for each block group. 

Q10. What is the value range of GiZScore?

7. On the map, you can see a “hot spot” in Boise and another in the large block group to the southwest.
Chapter 13
Task 1: Perform a Local Operation

4. Calculation is a temporary raster. Right-click Calculation, point to Data, and select Make Permanent. Name the permanent raster emidaft and click Save.

Chapter 14

Task 1.4 Create a Perspective View

4. You can tone down the color symbols for plne so that streams can stand out more. Select Properties from the context menu of plne. On the Display tab, enter 40 (%) transparency and click OK. (For ArcGIS 9.3 users, notice that the legend symbols for plne are also shown in 40% transparency.)
Task 2.3 Derive a Surface Curvature Layer
3. Right-click plne_curv and select Properties. On the Symbology tab, change the show type to Classified, click yes to compute unique values, and then click on Classify. In the Classification dialog, first select 6 for the number of classes and then enter the following break values: -4, -0.5, 0, 0.5, 4, and 6.34. Return to the Properties dialog, select a diverging color ramp (e.g., red to green diverging, bright), and click OK.
Task 3: Build and Display a TIN

2. Double-click the Raster to TIN tool in the 3D Analyst Tools/Conversion/From Raster toolset. Select emidalat for the input raster, specify emidatin for the output TIN, and change the Z Tolerance value to 10. Click OK to run the command.
Chapter 15
Task 4: Derive Upstream Contributing Areas at Pour Points

3. Select Raster Calculator from the Spatial Analyst dropdown menu. Enter the following expression in the expression box: watershed([flowdirection], [pourptgd]). Click Evaluate. The command creates Calculation as a temporary raster.
Challenge Task

1. The first step is to locate a gauge station in your local area. The USGS maintains a National Water Information System (NWIS) website, which provides a wide variety of water resource data. Go to http://nwis.waterdata.usgs.gov/nwis. Click on Real-time Data. You can now select a site location by state. Click the button for summary of additional data for this site. Write down the latitude and longitude readings of the gauge station as well as the datum (NAD27 or NAD83).
Chapter 16

Task 2: Use Kernel Density Estimation Method

3. To view kernel_d on top of deer, you can use the transparent option. Right-click kernel_d, select Properties, and click yes to build unique histogram. On the Display tab, enter 30% transparency. You can now see two layers superimposed on top of one another.
Task 3: Use IDW for Interpolation

3. The Step 1 panel includes a graphic frame and a method frame for specifying IDW parameters. The default IDW method uses a power of 2, 15 neighbors (control points), and a circular area from which control points are selected. The graphic frame shows stations and the points and their weights (shown in percentages and color symbols) used in deriving the estimated value for a test location. You can use the Identify Value tool to click any point within the graphic frame and see how the point’s estimated value is derived.
Chapter 17

(Replace Task 1 and Challenge Question with the following instructions. The data sets needed for the new Task 1 and Challenge Questions are provided at the website.)
Task 1: Geocode Street Addresses
What you need: streets, a street feature class of Kootenai County, Idaho derived from the 2000 TIGER/Line files; and cda_add, a table containing street addresses of 5 restaurants and 5 government offices in Coeur d’Alene, the largest city in Kootenai County. streets and cda_add are contained in kootenai.gdb, a file geodatabase. 
            In Task 1, you will learn how to create point features from street addresses. Address geocoding requires an address table and a reference dataset. The address table contains a list of street addresses to be located. The reference dataset has the address information for locating street addresses. Task 1 includes the following four steps: view the input data; create an address locator; run geocoding; and rerun geocoding for the unmatched addresses.

1. Start ArcCatalog, and connect to the Chapter 17 database. Launch ArcMap. Add streets and cda_add to Layers and rename Layers Task 1. Right-click streets and open its attribute table. Because streets is derived from the TIGER/Line files, it has all the attributes from the original data. Figure 17.2 has the descriptions of some of these attributes. Right-click cda_add, and open the table. The table contains the fields of Name, Address, and Zip. Close both tables.

2. Right-click the Chapter 17 database in ArcCatalog, point to New, and select Address Locator. In the Create New Address Locator dialog, select US Streets with Zone and click OK. 

3. Start with the left side of the New US Streets with Zone Address Locator dialog. Enter Task 1 for the name. Then select streets in kootenai.gdb for the reference data. Select FRADDL for the field of House From Left, TOADDL for House To Left, FRADDR for House From Right, and TOADDR for House To Right. Move to the right side of the dialog. In the Input Address Fields frame, first match Street with Address and delete others. To delete Addr, highlight it and click the Delete button. Delete Street. Next match Zone with Zip. Use the same procedure to delete Zipcode, City, and Zone. Keep the default values for spelling sensitivity, minimum candidate score, and minimum match score in the Matching Options frame. Click OK to dismiss the dialog. The address locator Task 1 is now added to kootenai.gdb.

Q1. The default spelling sensitivity value is 80. If you were to change it to 60, how would the change affect the geocoding process? 

Q2. What output options are available?

4. Go back to ArcMap. Click the Tools menu, point to Geocoding, and select Geocoding Addresses. Click Add in the next dialog, and add the address locator Task 1. Click OK. 

6. In the next dialog, make sure that cda_add is the address table and the address input fields (Address and Zip) are correct. Provide the path and save the output feature class as cda_geocode in kootenai.gdb. Click OK to geocode the addresses. 

7. The Geocoding Addresses dialog shows that 9 out of 10 addresses in cda_add are matched and 1 is unmatched. Click the Rematch button. In the Interactive Rematch –cda_geocode dialog, select Unmatched Addresses from the Show results dropdown list. The unmatched record is that of 2750 W KATHLEEN AVE. The address shows that the ZIP code is 83814. Enter the new ZIP code of 83815 in the Zone window. The Candidate window shows 21 candidates. Highlight the top candidate with a score of 100 and click Match. Click Close to dismiss the dialog. 

8. Geocoding Result: cda_geocode is added to the map. You need to zoom in to the city of Coeur d’Alene to see the 10 geocoded point features.

Challenge Task
What you need: coeurdalene_streets.shp, a street shapefile for Coeur d’Alene, Idaho; and cda_add.txt, a text file containing 10 street addresses in Coeur d’Alene. 

This challenge question asks you to geocode the 10 addresses in cda_add.txt, similar to Task 1. The difference is the input data: you will use a shapefile (coeurdalene_streets.shp) for the reference data and a text file (cda_add.txt) for the address table. Save your geocoding results into a shapefile.

Q1. Do you get the same result as in Task 1? 
Task 3: Analyze Two Event Layers

4. Similar to Task 2, you can use the Add Route Events tool to add Rest_Roadside as an event layer. The event layer can display the rest areas and their attributes such as the landscape classification.
Chapter 18
Task 3: Run Shortest Path Analysis

6. This step is to add Helena and Charlotte as stops for the shortest path analysis. Because the stops must be located on the network, you can use some help in locating them. Click the Route Properties button at the upper right of the Network Analyst window…
Task 4: Build a Geodatabase Network Dataset

4. Create a feature dataset. Right-click Network.mdb, point to New, and select Feature Dataset. In the next dialog, enter MoscowNet for the name. Then click Projected Coordinate Systems and Import to import the coordinate system of moscowst.shp to be MoscowNet’s coordinate system. Select None for Z coordinates. Take the default values for the tolerances. Then click Finish.
Task 5: Find Closest Facility

3. Right-click Facilities in the Network Analyst window, and select Load Locations. In the next dialog, make sure that the locations will be loaded from firestat, before clicking OK.  

4. Click the Closest Facility Properties button in the Network Analyst window. On the Analysis Settings tab, opt to find 1 facility and to travel from Facility to Incident. Uncheck the box for Oneway for emergency services. Click OK to dismiss the dialog…
Task 6: Find Service Area

3. This step sets up the parameters for the service area analysis. Click the Service Area Properties button in the Network Analyst window to open the dialog box. On the Analysis Settings tab, select Minutes for the impedance, enter “2, 5” for default breaks of 2 and 5 minutes, check direction to be away from Facility, and uncheck Oneway restrictions. On the Polygon Generation tab, check the box to generate polygons, opt for generalized polygon type and trim polygons, select not overlapping polygons per facility, and choose rings for the overlay type. Click OK to dismiss the Layer Properties dialog.

Chapter 19
Task 3: Build a Vector-Based Index Model

6. Insert a new data frame in ArcMap, and rename it Task 3. Add soil, landuse, depwater, and vulner from Task3.mdb to Task 3. (You will only be working with vulner; the other three feature classes are for reference.) Open the attribute table of vulner. TOTAL appears in the table with Nulls. Click the Options dropdown arrow and choose Select By Attributes. Enter the following SQL statement: “LURATE” < > 9.9. Click Apply. Right-click TOTAL and select Field Calculator. Click Yes in the Field Calculator message box. Enter the following expression in the Field Calculator dialog: 0.6 x [SOILRATE] + 0.2 x [LURATE] + 0.2 x [DWRATE]. Click OK to dismiss the dialog. The field TOTAL is populated with the calculated index values. You can assign a TOTAL value of -99 to urban areas. Click the Options dropdown arrow and select Switch Selection. Right-click TOTAL and select Field Calculator. Enter -99 in the expression box, and click OK. At this point, you have completed calculating the index value. Select Clear Selection from the Options dropdown arrow. Close the table.
Task 4: Build a Raster-Based Index Model

2. Click the Add Data button, and add depwater, landuse, and soil to the Task4 window…
