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Concepts Review

True/False Questions
Each of the following statements is either true or false. Indicate your 
choice by circling T or F.

 1. You cannot add records in a dynaset.

 2. You can build criteria by using logical and relational operators.

 3. You cannot use a query as the source of records for another query.

 4. You can add a field to a query in Design View by double-clicking the 
field name in the Field List window.

 5. Count and Sum are types of aggregate functions.

 6. Before using the Top Values property, you must sort a dynaset by its 
primary key.

 7. In the design grid, OR criteria are entered in the same row.

 8. The criteria “is not null” finds records with a blank or empty field.

Short Answer Questions
Write the correct answer in the space provided.

 1. What is the grid name of the lower pane of a query in which you sort 
data and enter criteria?

 2. In what view do you see the dynaset of a query?

 3. What property displays the highest or lowest values?

 4. What type of criteria do you use when you want two conditions to be 
true at the same time?

 5. In the Design View of a query, what row displays “Group By” or 
“Count”?

 6. In Access, what keyword(s) means is “blank” or is “empty”?
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 7. When you key a wildcard in a query, what operator does Access use to 
compare your criteria with each record?

 8. What symbol represents “not equal?”

Critical Thinking
Answer these questions on a separate page. There are no right or wrong 
answers. Support your answers with examples from your own experience, 
if possible.

 1. When an expression has two or more math operators, the Expression 
Builder follows the mathematical order of operations rules. List these 
rules, as well as all symbols used with each of them, and give examples 
of their use.

 2. AND and OR criteria are common to databases, programming, and 
spreadsheets. You can build a logic table to help you visualize what 
happens with two criteria in these situations. Complete this table (on a 
separate sheet of paper) to show if the result is True or False (a match 
or no match).

Figure 6-23
Logic table

Skills Review

Exercise 6-21
Create a select query. Add and remove fields to a query. Add a calculation. 
Sort a query. Print/Save a query’s dynaset and Documenter report.

 1. Open a database by following these steps:

 a. Locate and open the Lesson 06 folder.

 b. Make a copy of CC06 and rename it to [your initials]-CC06.

 c. Open and enable content for [your initials]-CC06.
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 2. Create the query by following these steps:

 a.  From the Create tab, in the Other group, click the Query Design 
command .

 b.  In the Show Table dialog box, double-click tblEmployees and click 
Close.

 c. Resize the Field List so all fields can be seen.

 d.  From the tblEmployees Field List, double-click EmployeeID, LastName 
and FirstName.

 e.  From the Quick Access toolbar, click Save . Name the query 
06-21-[your initials].

 3. Add a calculation to a query by following these steps:

 a. In the design grid, click in the forth column.

 b.  From the Design tab, in the Query Setup group, click the Builder 
command .

  c.  In the middle panel, double-click LastName.

  d.  In the expression box, after “[LastName]” key 
&“, ”& (ampersand, double quote, comma, space, 
double quote, amperstand.)

  e.  In the middle panel, double-click FirstName.

 f. Click OK.

 g.  Replace “Expr1” with FullName. Be certain to leave the colon after 
the field name.

 4. Sort and delete fields by following these steps:

 a.  In the Sort row for FullName, click the drop-down arrow and choose 
Ascending.

 b.  In the design grid, select both the LastName and the FirstName fields. 
Press  to remove the fields from the design grid.

 c.  From the Quick Access toolbar, click Save .

 d.  From the Design tab, in the Results group, click the View command 
 to switch to Datasheet View.

 e. Size columns appropriately.

 5.  Print/Save a query’s dynaset and Documenter report by following these 
steps:

 a.  Click the Office Button . From the Print option, choose Print 
Preview .

 b. Print/Save the query.

 c. Close Print Preview and the query.

 d.  From the Database Tools tab, in the Analyze group, click the Database 
Documenter command .

 e.  From the Documenter dialog box, click the query 06-21-[your initials] 
checkbox and click Options.

 f.  Only include Properties and SQL for the query and nothing else. 
Click OK.

 g. Click OK to go to Print Preview.

NOTE

Make sure that you add a space after the 
comma in the quotes.
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 h.  From the Print Preview tab, in the Page Layout group, click Margins 
and choose the Wide command  from the menu.

 i. Print/Save the report.

 j. Close Print Preview.

Exercise 6-22
Create a query with a wizard. Add criteria to a query. Sort and hide a field. 
Print/Save a dynaset.

 1. Use the Simple Query Wizard by following these steps:

 a. Open and enable content for [your initials]-CC06.

 b.  From the Create tab, in the Other group, click the Query Wizard 
command .

 c. In the New Query dialog box, double-click Simple Query Wizard.

 d. From the Tables/Queries list box, choose Table: tblEmployees.

 e.  In the Available Fields list, double-click LastName, FirstName, and 
JobCode.

 f. From the Tables/Queries list box, choose Table: tblJobCodes.

 g. In the Available Fields list, double-click JobTitle.

 h. From the Tables/Queries list box, choose Table: tblPay.

 i. In the Available Fields list, double-click EmpPay and PayClass.

 j. Click Next. The default type of select query is Detail. Click Next.

 k. Delete the suggested title and key 06-22-[your initials]. Click Finish.

 2. Add criteria to fields by following these steps:

 a. Switch to Design View. Resize and move each Field List.

 b. In the Criteria row for JobCode, key mf03, press , and key mf04.

 c.  In the Criteria row for PayClass, key 2, and press , and key 2. Pay 
class 2 represents hourly employees.

 3. Sort and hide a field by following these steps:

 a.  In the Sort row for JobTitle, click the drop-down arrow and choose 
Ascending.

 b.  In the Show row for PayClass, remove the checkmark. This field is 
only needed for criteria, so there is no need to include it in the final 
dynaset.

 c. Switch to Datasheet View. Resize each field appropriately.

 4. Print/Save a query’s dynaset by following these steps:

 a.  Click the Office Button . From the Print option, choose Print 
Preview .

 b. Print/Save the query.

 c. Close Print Preview and the query.
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Exercise 6-23
Create a query in Design View. Add a criterion to a query. Sort and show 
the top 5% of records. Print/Save a dynaset and Database Documenter 
report.

 1. Create a query in Design View by following these steps:

 a. Open and enable content for [your initials]-CC06.

 b.  From the Create tab, in the Other group, click the Query Design 
command .

 c.  In the Show Table dialog box, double-click tblInvoices, 
tblInvoiceLineItems, and tblStuffedAnimals. Click Close.

 d. Resize the Field List so all fields can be seen.

 e.  From the tblInvoices Field List, double-click InvoiceID, ShipDate, and 
CustomerID.

 f. From the tblStuffedAnimals Field List, double-click ProductName.

 g. From the tblInvoiceLineItems Field List, double-click Qty.

 h.  From the Quick Access toolbar, click Save . Name the query 
06-23-[your initials].

 2. Add a criterion to a field by following these steps:

 a.  In the Criteria row for ShipDate, key between 10/1/2006 and 
1/1/2007.

 3. Sort and show the top 5% of records by following these steps:

 a.  In the Sort row for Qty, click the drop-down arrow and choose 
Descending.

 b.  From the Design tab, in the Query Setup group, click the Return list 
box  (Top Value) and choose 5%.

 c. Switch to Datasheet View. Resize columns appropriately.

 4.  Print/Save a query’s dynaset and Documenter report by following these 
steps:

 a.  Click the Office Button . From the Print option, choose Print 
Preview .

 b. Print/Save the query.

 c. Close Print Preview and the query.

 d.  From the Database Tools tab, in the Analyze group, click the Database 
Documenter command .

 e.  From the Documenter dialog box, click the 06-23-[your initials] check 
box and click Options.

 f.  Only include Properties and SQL for the query and nothing else. 
Click OK.

 g. Click OK to go to Print Preview.
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 h.  From the Print Preview tab, in the Page Layout group, click Margins 
and choose the Wide command  from the menu.

 i. Print/Save the report.

 j. Close Print Preview.

Exercise 6-24
Create a query in Design View. Add a criterion to a field. Modify a query 
PivotChart view. Print a PivotChart and Database Documenter report.

 1. Create a query in Design View by following these steps:

 a. Open and enable content for [your initials]-CC06.

 b.  From the Create tab, in the Other group, click the Query Design 
command .

 c.  In the Show Table dialog box, double-click tblEmployees and 
tblLeaveDays. Click Close.

 d. Resize the Field List so all fields can be seen.

 e. From the tblEmployees Field List, double-click JobCode.

 f.  From the tblLeaveDays Field List, double-click LeaveDate and 
LeaveCategory.

 g.  From the Quick Access toolbar, click Save . Name the query 
06-24-[your initials].

 2. Add a criterion by following these steps:

 a. In the Criteria row for JobCode, key m*.

 3. Modify a PivotChart view by following these steps:

 a.  Switch to PivotChart View. From the Chart Field List, click the 
Expand button  for LeaveDate By Month. Drag the Months into the 
Drop Category Fields Here zone (bottom of the chart) of the PivotChart.

 b.  From the Chart Field List, drag the LeaveCategory into the Drop 
Series Fields Here zone (right of the chart) of the PivotChart.

 c.  From the Chart Field List, drag the LeaveCategory into the Drop Data 
Fields Here zone (middle of the chart) of the PivotChart. The default 
function for this data type is Count.

 d.  Close the Chart Field List. From the Design tab, in the Tools group, 
click the Property Sheet command .

 e.  On the PivotChart, click the Value Axis (left of the chart). In the 
Properties dialog box, click the Format tab. Change the Caption 
property to Number of days.

 f.  On the PivotChart, click the Category Axis (bottom of the chart). In 
the Properties dialog box, change the Caption property to Year to date. 
Close the Properties dialog box.

 g.  From the Design tab, in the Show/Hide group, click the Drop Zone 
command  to remove the zone markers.
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 h.  From the Design tab, in the Show/Hide group, click the Legend 
command  to add the Legend to the PivotChart.

 i. Save the query.

 4.  Print/Save a query’s dynaset and Database Documenter report by 
following these steps:

 a.  Click the Office Button . From the Print option, choose Print 
Preview .

 b.  From the Print Preview tab, in the Page Layout group, click the 
Landscape command  from the menu.

 c. Print/Save the query’s PivotChart View.

 d. Close Print Preview and the query.

 e.  From the Database Tools tab, in the Analyze group, click the 
Database Documenter command .

 f.  From the Documenter dialog box, click the 06-24-[your initials] check 
box and click Options.

 g.  Only include Properties and SQL for the query and nothing else. Click 
OK.

 h. Click OK to go to Print Preview.

 i.  From the Print Preview tab, in the Page Layout group, click Margins 
and choose the Wide command  from the menu.

 j. Print/Save the report.

 k. Close Print Preview.
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Exercise 6-25
Create a query using a Simple Query Wizard.

 1. Open [your initials]-CC06.

 2. Launch the Simple Query Wizard.

 3. From tblEmployee, use the fields LastName and FirstName. From tblRegions, 
add RegionName.

 4. Save the query as 06-25-[your initials].

 5. Sort the dynaset in ascending order by LastName.

 6. Print/Save the Datasheet View of the query.

Exercise 6-26
Create query in Design View.

 1. Using [your initials]-CC06, create a new query in Design View.

 2. From tblEmployees, add the fields LastName and FirstName.

 3. From tblEmployeeDates, add the field HireDate and remove the Show 
checkmark.

 4. Create a calculated field using the function DateDiff(“yyyy”,[HireDate],
now()). Set the format to 0“ years” and the alias to Tenure.

 5. For the field Tenure, sort in descending order.

 6. From tblEmployeeDates, add the field EndDate.

 7. For the field EndDate, set the criterion to Is Null and remove the Show 
checkmark.

 8. Set Top Value to 5.

 9. Name the query 06-26-[your initials].

 10. Print/Save the Datasheet View of the query.

 11. Print/Save a Database Documenter report displaying only the Properties 
and SQL options for the query.
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Lesson Applications
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Exercise 6-27
Create a query in Design View.

 1. Using [your initials]-CC06, create a new query in Design View.

 2. Include tblCustomers, tblInvoices, tblInvoiceLineItems, and 
tblStuffedAnimals.

 3. From tblCustomers, add CompanyName.

 4. From tblInvoiceLineItems, add the field Qty field and remove the Show 
checkmark.

 5. From tblStuffedAnimals, add the field UnitPrice and remove the Show 
checkmark.

 6. Create a calculated field by multiplying the field Qty by the field 
UnitPrice. Set the format to currency with two decimal places and the 
alias to Revenue.

 7. In PivotChart View, perform the following actions:

  • Add CompanyName to the X-axis.

  • Add Revenue to the Data area with a default function of SUM.

  • Rename the X-axis to Customers-[your full name].

  • Rename the Y-axis to Total Sales.

  • Remove the drop zones.

 8. Save the query as 06-27-[your initials].

 9. Print/Save PivotChart View in Landscape layout.

10. Print/Save a Database Documenter report displaying only the Properties 
and SQL options for the query.

Exercise 6-28  Challenge Yourself
Create a query in Design View.

 1. Using [your initials]-CC06, create a new query in Design View.

 2. Include tblEmployees, tblPayrollHistory, tblPayrollRates, and tblPay.

 3. From tblEmployees, add LastName, FirstName, and JobCode.

 4. From tblPayrollHistory, add PayNum and OvHr.

 5. From tblPayrollRates, add OverTime.

 6. From tblPay, add EmpPay.

 7. Create a calculated field using the expression OvHr multiplied by 
EmpPay multiplied by OverTime. Set the format to currency with two 
decimal places and the alias to Over Time Cost.
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 8. Using a single Criteria row, perform the following:

    • For the field JobCode, set the criterion to m*.

     • For the field PayNum, set the criterion to >�23.

     • For the field OvHr, set the criterion to Is Not Null.

 9. Name the query 06-28-[your initials].

10.  Print/Save the Datasheet View of the query in 
Landscape orientation.

11.  Print/Save a Database Documenter report displaying only the Properties 
and SQL options for the query.

NOTE

Only eight records will appear in the 
dynaset when the criteria are properly 

applied.

On Your Own
In these exercises, you work on your own, as you would in a real-life work 
environment. Use the skills you’ve learned to accomplish the task—and be 
creative.

Exercise 6-29
Review the design of the database that you modified in Exercise 5-28. On 
a sheet of paper, list information that a user of your database might need. 
Design three queries that might provide the information needed. Use a variety 
of query types. Write your name and Exercise 6-29. Before proceeding to 
the next exercise, have your instructor approve your database design and 
intentions. Continue to the next exercise.

Exercise 6-30
Create the queries you designed in Exercise 6-29. Enter at least five 
additional records into each table of the database. Print the tables. Review 
the design of the database. On a sheet of paper, design a dynaset that 
incorporates data from two or more tables. Identify the type of query 
needed to create the dynaset. On the same sheet of paper, list all fields to 
be used in the query. For each field, include the name of the table from 
which the field originates. Identify the key fields and any foreign fields. 
Write down the criteria that would be required for the query. Name the 
query appropriately. Write your name and “Exercise 6-30” on each sketch. 
Continue to the next exercise.
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Exercise 6-31
Based on the designs that you created in Exercises 6-29 and 6-30, create the 
queries. Print the definitions for each query. Print a copy of the dynaset for 
each query. Submit to your instructor your designs and the printouts that 
you created for Exercises 6-29 through 6-31. Keep a copy of the database you 
modified in this exercise. You will use it for the On Your Own exercises in 
subsequent lessons.
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