


6. In what view can you change the data type or description of a field?

7. In Design View, which function key toggles the insertion point between 
the lower and upper panes?

8. What kind of field must store unique or different data for each record?

Critical Thinking
Answer these questions on a separate page. There are no right or wrong 
answers. Support your answers with examples from your own experience, 
if possible.

1. Access Templates use field names such as StateOrProvince and 
PostalCode instead of State or ZIPCode. Why do you think Access does 
this? Give an example when using the default field names might not be 
appropriate.

2. Many businesses find it necessary to import tables into Access. Give an 
example when a business might need to import data.

Skills Review

Exercise 4-20
You have been asked to create a new database to help track tasks for 
company employees. You create a new database to manage these tasks.

1. Create a new database by following these steps:

a.  With Access running and no database open, click Sample templates 
and choose Tasks.

b. In the File Name textbox, key [your initials]-EcoMed-Tasks.

c. Verify the save location.

d. Click Create .

2. Change the appearance of the Navigation Pane by following these steps:

a. Click Enable Content.

b.  Expand the Navigation Pane, click the Task Navigation bar, and 
choose Object Type.

c. Close the form Task List.

d. Double-click the table Tasks.
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3. Delete fields in Datasheet View by following these steps:

a. Click on the column header for the Description.

b. From the Fields tab, in the Add & Delete group, click Delete .

4. Delete fields in Design View, by following these steps:

a. From the Home tab, in the Views group, click View  to switch to 
Design View.

b. Click on the field selector for Attachments.

c. From the Design tab, in the Tools group, choose Delete Rows .

d. Press Ctrl + S  to save the changes.

5. Change field properties by following these steps:

a. Click on the field selector for Title.

b. In the property Field Size, key 200.

c. Press Ctrl + S  to save the changes.

6. Close an object by following these steps:

a. Right-click the Tasks tab. From the shortcut menu, select Close .

Assessment

- Close the database.

-  According to your classroom procedure, turn in your database only when 
you have completed all assigned exercises.

-OR-

- Create a Database Documenter report by following these steps:

 a.  From the Database Tools tab, in the Analyze group, choose Database 
Documenter .

 b.  In the Documenter dialog box, on the Tables tab, click the check box 
for Tasks.

 c. Click Options to open the Print Table Definition dialog box.

 d. For the Include for Table section, check Properties.

 e. For the Include for Fields section, select Names, Date Types, and Size.

 f. For the Include for Indexes section, select Nothing.

 g. Click OK to close the Print Table Definition dialog box.

 h. Click OK to create the document report.

- Save a Database Documenter report by following these steps:

 a.  From the Print Preview tab, in the Data group, click PDF or XPS  to 
save the printout as a file.

 b. Save the file with the following settings:

• In the dialog box’s Navigation Pane, select the location where you 
want to store your class work.

• Save as type as PDF.

• File name as [your initials]-04-20-A.

• Open file after publishing should be checked.
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 c. Close the Export – PDF window.

 d. Depending on your class procedures, print or turn in the PDF file.

 e.  From the Print Preview tab, in the Close Preview group, click Close Print 
Preview .

 f. Close the database.

Exercise 4-21
The structure for the table inventory needs to be modified. Using Design 
View, modify the structure and then verify your work by saving a 
documenter report.

1. Locate and copy a database by following these steps:

a. Locate and open the Lesson 04 folder.

b. If you already have a copy of [your initials]-EcoMed-04, skip to step 2.

c. Right-click the file EcoMed-04 and from the shortcut menu, 
choose Copy.

d. Right-click an unused part of the folder. From the shortcut menu, 
choose Paste.

e. Right-click the new file and from the shortcut menu, choose Rename. 
Rename the file to [your initials]-EcoMed-04.

f. Right-click [your initials]-EcoMed-04 and from the shortcut menu, 
choose Properties. Make certain that the Read-only attribute check 
box is not checked. Click OK.

2. Change the design of a table by following these steps:

a. Open tblInventory. Switch to Design View.

b. In the top pane, click in the BulbShapes row and press F6 .

c. In the Field Size, key 20.

d. In the top pane, click in the BulbCategory row and press F6 .

e. In the Field Size, key 15.

f. In the top pane, click in the 3Way.

g. From the Design tab, in the Tools group, click Delete Rows . Click 
Yes to confirm the deletion.

h. In the top pane, click in the EnergyStar.

i. From the Design tab, in the Tools group, click Insert Rows .

j. Key Available as the new Field Name.

k. Press Tab  and choose Yes/No as the new Data Type.

3. Close an object by following these steps:

a. Right-click the tblInventory tab. From the shortcut menu select 
Close .

b. Save the changes to the table and click Yes when warned that some 
data might be lost.
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Assessment

-  According to your classroom procedure, turn in your database only when 
you have completed all assigned exercises.

-OR-

- Create a Database Documenter report by following these steps:

 a.  From the Database Tools tab, in the Analyze group, click Database 
Documenter .

 b.  In the Documenter dialog box, on the Tables tab, click the check box for 
tblInventory.

 c. Click Options to open the Print Table Definition dialog box.

 d. For the Include for Table section, check Properties only.

 e. For the Include for Fields section, select Names, Data Types, and Size.

 f. For the Include for Indexes section, select Nothing.

 g. Click OK to close the Print Table Definition dialog box.

 h. Click OK to create the document report.

- Save a Database Documenter report by following these steps:

 a.  Click the File tab. From the Print option, choose Print Preview .

 b.  From the Print Preview tab, in the Data group, click PDF or XPS  to 
save the printout as a file.

 c. Save the file with the following settings:

• In the dialog box’s Navigation Pane, select the location where you 
want to store your class work.

• Save as type as PDF.

• File name as [your initials]-04-21-A.

• Open file after publishing should be checked.

 d. Close the Export – PDF window.

 e. Depending on your class procedures, print or turn in the PDF file.

 f.  From the Print Preview tab, in the Close Preview group, click Close Print 
Preview .

Exercise 4-22
The structure for the table bulb shapes needs to be modified. Using 
Design View, modify the structure, then verify your work by saving a 
documenter report.

1. The database [your initials]-EcoMed-04 is required to complete this 
exercise.

a. Double-click the database [your initials]-EcoMed-04.

b. If the Message Bar’s Security Warning appears, click the Enable 
Content button.
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2. Add fields by following these steps:

a. Open tblBulbShapes. Switch to Design View.

b. In the top pane, click in the BulbShape row.

c. From the Design tab, in the Tools group, select Insert Row .

d. For the Field Name key BulbShapeID.

e. For the Data Type select AutoNumber.

3. Change a field’s properties by following these steps:

a. From the Design tab, in the Tools group, select Primary Key .

b. Double-click to select the field name BulbShape. Press Ctrl + C .

c. Press F6 . Change the Field Size to 30.

d. In the Format property, key >.

e. Press  until you reach the Caption property. Press Ctrl + V .

f. Add a space between the words “Bulb” and “Shape.”

4. Close an object by following these steps:

a. Right-click the tblBulbShapes tab. From the shortcut menu, select 
Close .

b. Save the changes to the table and click Yes when warned that some 
data might be lost.

Assessment

-  According to your classroom procedure, turn in your database only when 
you have completed all assigned exercises.

-OR-

- Create a Database Documenter report by following these steps:

 a.  From the Database Tools tab, in the Analyze group, choose Database 
Documenter .

 b.  In the Documenter dialog box, on the Tables tab, click the check box for 
tblBulbShapes.

 c. Click Options to open the Print Table Definition dialog box.

 d. For the Include for Table section, check Properties.

 e.  For the Include for Fields section, select Names, Data Types, Size, and 
Properties.

 f. For the Include for Indexes section, select Nothing.

 g. Click OK to close the Print Table Definition dialog box.

 h. Click OK to create the document report.

- Save a Database Documenter report by following these steps:

 a. Click the File tab. From the Print option, choose Print Preview .

 b.  From the Print Preview tab, in the Data group, click PDF or XPS  to 
save the printout as a file.
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 c. Save the file with the following settings:

• In the dialog box’s Navigation Pane, select the location where you 
want to store your class work.

• Save as type as PDF.

• File name as [your initials]-04-22-A.

• Open file after publishing should be checked.

 d. Close the Export – PDF window.

 e. Depending on your class procedures, print or turn in the PDF file.

 f.  From the Print Preview tab, in the Close Preview group, click Close Print 
Preview .

Exercise 4-23
New bulbs to be added to the inventory table have been entered into an 
Excel spreadsheet. Rather than retype the information, you have been 
instructed to import the records from the spreadsheet and append these 
records into the inventory table.

1. The database [your initials]-EcoMed-04 is required to complete this 
exercise.

a. Double-click the database [your initials]-EcoMed-04.

b. If the Message Bar’s Security Warning appears, click the Enable 
Content button.

2. Import Excel data by following these steps:

a. From the External Data tab, in the Import & Link group, click Excel .

b. In the Get External Data dialog box, click Browse.

c. Locate the Lesson 04 folder and select New Bulbs. Click Open.

d. Select the Append a copy of the records to the table:  option. Select 
the table tblInventory. Click OK.

e. Click Finish.

f. The message box tells you that the table has been imported. Click Close.

g. Open tblInventory in Datasheet View.

3. Filter the table by following these steps:

a. Click anywhere in the BulbShapes field.

b. From the Home tab, in the Sort & Filter group, click Filter .

c. Click the  (Select All) check box to remove the checkmark.

d. Scroll down the list and click on Other. Click OK.

e. Resize each column to show all the data.
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4. Hide fields in a table by following these steps:

a. Select the field header Available.

b. From the Home tab, in the Records group, click More  and choose 
Hide Fields.

c. Select the field header Wattage through Color Temp.

d. From the Home tab, in the Records group, click More  and choose 
Hide Fields.

e. Save the changes to the table.

5. Change the print settings for a datasheet by following these steps:

a. Click the File tab. From the Print option, choose Print Preview .

b. From the tab Print Preview, in the Page Layout group, click 
Landscape .

Assessment

- Close an object by following these steps:

 a. Right-click the tblInventory tab. From the shortcut menu, select Close .

 b. Compact and close the database.

-  According to your classroom procedure, turn in your database only when 
you have completed all assigned exercises.

-OR-

- Save datasheet for a table by following these steps:

 a.  From the Print Preview tab, in the Data group, click PDF or XPS  to 
save the printout as a file.

 b. Save the file with the following settings:

• In the dialog box’s Navigation Pane, select the location where you 
want to store your class work.

• Save as type as PDF.

• File name as [your initials]-04-23-A.

• Open file after publishing should be checked.

 c. Close the Export – PDF window.

 d. Depending on your class procedures, print or turn in the PDF file.

- Close an object by following these steps:

 a. Right-click the tblInventory tab. From the shortcut menu, select Close .

 b. Compact and close the database.
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Exercise 4-24
The sales department needs to send marketing literature to the Chief 
Executive Officers (CEOs) of all client facilities. Rather than have the sales 
department work with the full database, you have been asked to create a 
temporary facilities database. You will import the facilities table from the 
EcoMed database and add a CEO field to the table.

1. Create a blank database named [your initials]-EcoMed-Facility.

2. Import tblFacilities from [your initials]-EcoMed-04.

3. Rename the table tblFacility.

4. Add a text field named CEO as the last field of the table.

5. Set the field size to 50.

Assessment

- Close and save the table, then compact and close the database.

-  According to your classroom procedure, turn in your database only when 
you have completed all assigned exercises.

-OR-

-  Create a Database Documenter report for tblFacility using the following 
settings:

• Include for Table: Properties only

• Include for Fields: Names, Data Types, and Size

• Include for Indexes: Nothing

- Save the Documenter report as a PDF file named [your initials]-04-24-A.

- According to your class procedures, print or turn in the PDF file.

- Close the Export – PDF window.

- Close and save the table, then compact and close the database.

Exercise 4-25
The sales department has determined that the company now needs to 
track sales events. You have been asked to add a new table to the existing 
database.

1. Use the database [your initials]-EcoMed-04 database.

2. Create a new table named tblSalesEvent.

Lesson Applications
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3. Open the table in Design View. Add the following fields to the table.

 Field Data Type Caption
 SalesRep Text Sales Representative
 StartDate Date/Time Start Date
 EndDate Date/Time End Date

4. Change the Format to Short Date for the StartDate and EndDate fields.

5. Add Short Date Input Mask for both dates.

6. Change the Field Size property for Sales Rep to 35.

7. Rename the field ID to SaleEventID.

Assessment

- Close and save the table, then compact and close the database.

-  According to your classroom procedure, turn in your database only when 
you have completed all assigned exercises.

-OR-

-  Create a Database Documenter report for tblSalesEvent using the following 
settings:

• Include for Table: Nothing

• Include for Fields: Names, Data Types, Size, and Properties

• Include for Indexes: Nothing

-  Save the Documenter report as a PDF file named [your initials]-04-25-A.

- According to your class procedures, print or turn in the PDF file.

- Close and save the table, then compact and close the database.

Exercise 4-26
On occasion, employees purchase supplies for the company. These expenses 
need to be tracked. Create a new table to track employee expenses.

1. Using the database [your initials]-EcoMed-04 database, create a new 
blank table.

2. In Datasheet View, add the following record:

 ID: Press TabTab

 Column 2: 464-4824
 Column 3: Supplies
 Column 4: 10/15/11
 Column 5: $14.85
 Column 6: Cleaning Supplies
 Column 7: Trash Bags, Soap, and Paper Towels

TIP

To add a new field in Datasheet View, you 
must click in the Click to Add column.
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3. Save the table as tblEmpExp-[your initials].

4. Set Field1 as the primary key and delete the ID field.

5. Rename the field names to the following:

 Field1: EmpID
 Field2: ExpenseType
 Field3: DatePurchased
 Field4: AmountSpent
 Field5: Purpose
 Field6: Description

6. Set the Caption for EmpID to Employee ID.

7. Create appropriate captions, by adding a space, for the fields 
ExpenseType, DatePurchased, and AmountSpent.

8. Enter the following record:

 Employee ID: 234-7890
 Expense Type: Supplies
 Date Purchased: 10/22/11
 Amount Spent: $25.34
 Purpose: Office Supplies
 Description: Key [your full name]

9. Resize columns so all data is visible.

Assessment

- Close and save the table, then compact and close the database.

-  According to your classroom procedure, turn in your database only when 
you have completed all assigned exercises.

-OR-

-  Save the table tblEmpExp as a PDF file named [your initials]-04-26-A, 
in landscape orientation.

- According to your class procedures, print or turn in the PDF file.

- Close and save the table, then compact and close the database.
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Exercise 4-27  Challenge Yourself
Normally, EcoMed payments are tracked by the accounting department 
through a separate application. The director of the IT department would 
like to test tracking expenses through the current access database. Create 
a new database and add the appropriate table.

1. Create a blank database and name it [your initials]-Application-04.

2. Create a new table named tblPayments-[your initials], and use 
Design View to add the following fields:

 Field Name Data Type Field Size
 PaymentID AutoNumber
 CustomerID Number Integer
 OrderID Number Integer
 PaymentAmount Currency
 PaymentDate Date/Time
 Description Text 40

3. Delete the Field ID.

4. Set PaymentID as the primary key.

Assessment

- Close and save the table, then compact and close the database.

-  According to your classroom procedure, turn in your database only when 
you have completed all assigned exercises.

-OR-

-  Create a Database Documenter report for tblPayments using the following 
settings:

• Include for Table: Properties only

• Include for Fields: Names, Data Types, and Size

• Include for Indexes: Nothing

- Save the Documenter report as a PDF file named [your initials]-04-27-A.

- According to your class procedures, print or turn in the PDF file.

- Close and save the table, then compact and close the database.
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On Your Own

In these exercises you work on your own, as you would in a real-life work 
environment. Use the skills you’ve learned to accomplish the task—and be 
creative.

Exercise 4-28
Using the Contact Template, create a new database to store the member 
information you collected and organized for the On Your Own exercises of 
Lessons 1 through 3. Enter the member information. Print the datasheet 
view of the table. On the first sheet of your printout, write your name and 
class information. Continue to Exercise 4-29.

Exercise 4-29
Review the structure of the main table in the database you created in 
Exercise 4-28. On a blank sheet of paper, list the fields, data types, and field 
sizes from the table that are most appropriate for your organization’s needs. 
Add any additional fields that would improve the usability of the table. 
Without using a database template, create a blank database. Create a table 
to store the data. Enter the member information. Print properties for the 
table. Continue to Exercise 4-30.

Exercise 4-30
Search the Templates section of the Microsoft Office home page. Locate a 
template that will enhance the database you created in the previous 
exercise. Using the template you located on the Internet, create a new 
database. Enter appropriate data for at least five records. Print the table. 
Submit to your instructor the printouts from Exercises 4-28 through 4-30 
along with your field list from 4-30. Make sure your name, the date, and 
your class information is written on the printouts. Keep a copy of the three 
databases you created in Exercises 4-28 through 4-30. They may be used in 
subsequent lessons.
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