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True/False Questions
Each of the following statements is either true or false. Indicate your 
choice by circling T or F.

1. A dynamic recordset automatically changes its underlying data source.

2. You can build criteria by using logical and relational operators.

3. You cannot use a query as the source of records for another query.

4. You can add a field to a query in Design View by double-clicking the 
field name in the Field List window.

5. Count and Sum are types of aggregate functions.

6. Before using the Top Values property, you must sort a dynaset by its 
primary key.

7. In the design grid, OR criteria are entered in the same row.

8. The criteria “is not null” finds records with a blank or empty field.

Short Answer Questions
Write the correct answer in the space provided.

1. What is the grid name of the lower pane of a query in which you sort 
data and enter criteria?

2. In what view do you see the dynaset of a query?

3. What property displays the highest or lowest values?

4. What type of criteria do you use when you want two conditions to be 
true at the same time?

5. What is the operation of joining two or more character strings end to end?

6. In Access, what keyword(s) means is “blank” or is “empty”?

Concepts Review
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7. When you key a wildcard in a query, what operator does Access use to 
compare your criteria with each record?

8. What symbol represents “not equal”?

Critical Thinking
Answer these questions on a separate page. There are no right or wrong 
answers. Support your answers with examples from your own experience, 
if possible.

1. When an expression has two or more math operators, the Expression 
Builder follows the mathematical order of operations rules. List these 
rules and the symbols used with them, and give examples of their use.

2. AND and OR criteria are common to database, programming, and 
spreadsheets. You can build a logic table to help you visualize what 
happens with two criteria in these situations. Complete Figure 6-32 (on 
a separate sheet of paper) to show if the result is True or False (a match 
or no match).

Skills Review

Exercise 6-22
You have been asked to create a query to display the names of employees 
for a specific job code. Follow these steps to create the query.

1. Open a database by following these steps:

a. Locate and open the Lesson 06 folder.

b. If you already have a copy of [your initials]-EcoMed-06, skip to 
step 1d.

c. Make a copy of EcoMed-06 and rename it [your initials]-EcoMed-06.

d. Open and enable content for [your initials]-EcoMed-06.

Figure 6-32
Logic table
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2. Use the Simple Query Wizard by following these steps:

a. From the Create tab, in the Queries group, click Query Wizard .

b. In the New Query dialog box, double-click Simple Query Wizard.

c. From the Tables/Queries list box, choose Table: tblEmployees.

d. In the Available Fields list, double-click LastName, FirstName, and 
JobCode.

e. From the Tables/Queries list box, choose Table: tblJobCodes.

f. In the Available Fields list, double-click JobTitle.

g. From the Tables/Queries list box, choose Table: tblPay.

h. In the Available Fields list, double-click EmpPay.

i. Click Next. The default type of select query is Detail. Click Next.

j. Delete the suggested title and key qryEmpPay. Click Finish.

3. Add criteria to fields by following these steps:

a. Switch to Design View.

b. In the Criteria row for JobCode, key mf03, press , and key mf04.

c. From the Design tab, in the Results group, click Run .

d. Switch to Design View.

4. Sort and hide a field by following these steps:

a. In the Sort row for JobTitle, click the drop-down arrow and choose 
Ascending.

b. In the Show row for JobCode, remove the checkmark. This field is only 
needed for criteria, so there is no need to include it in the final dynaset.

c. Switch to Datasheet View.

d. Save and close the query.

Assessment

-  According to your classroom procedure, turn in your database only when 
you have completed all assigned exercises.

-OR-

- Create a Database Documenter report for qryEmpPay following these steps:

 a. From the Database Tools tab, in the Analyze group, click Database 
Documenter.

 b. In the Documenter dialog box, click the Queries tab, and select 
qryEmpPay. Click Options.

 c. For Query, include Properties and SQL.

 d. From the Include for Fields section, choose Nothing.

 e. From the Include for Indexes section, choose Nothing.

 f. Click OK twice to go to Print Preview.
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- Save a Documenter report by following these steps:

 a.  From the Print Preview tab, in the Data group, click PDF or XPS  to 
save the printout as a file.

 b. Save the file as a PDF and name the file [your initials]-06-22-A.

 c. Depending on your class procedures, print or turn in the PDF file.

 d. Close Print Preview and the query.

Exercise 6-23
Create a query to display the names of all the interns. Include the names 
of the intern identification number and concatenate the first and last 
names together.

1. The database [your initials]-EcoMed-06 is required to complete this 
exercise.

a. Open and enable content for [your initials]-EcoMed-06.

2. Create the query by following these steps:

a. From the Create tab, in the Queries group, click Query Design .

b. In the Show Table dialog box, double-click tblInterns and click Close.

c. Resize the Field List so all fields can be seen.

d. From the tblInterns Field List, double-click InternID, LastName, and 
FirstName.

e. From the Quick Access toolbar, click Save . Name the query qryIntern.

3. Add a calculated field to a query by following these steps:

a. In the design grid, click in the fourth column in the Field row.

b. From the Design tab, in the Query Setup group, click Builder .

c. In the Expression Categories panel, double-click LastName.

d. In the Expression box after [LastName], key & “, “ &.

e. In the Expression Categories panel, double-click 
FirstName. Click OK.

f. In the calculated field, modify the alias by replacing 
“Expr1” with Full Name.

4. Sort and delete fields by following these steps:

a. In the Sort row for Full Name, click the drop-down arrow and choose 
Ascending.

b. In the design grid, select both LastName and FirstName fields. 
Press Delete  to remove the fields from the design grid.

c. From the Quick Access toolbar, click Save .

d. From the Design tab, in the Results group, click Run .

e. Save and close the query.

06-22-A.pdf 
1 Page

NOTE

Make sure that you add a space after the 
comma inside of the quotes.
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Assessment

-  According to your classroom procedure, turn in your database only when 
you have completed all assigned exercises.

-OR-

- Create a Database Documenter report for qryIntern following these steps:

 a.  From the Database Tools tab, in the Analyze group, click Database 
Documenter.

 b.  In the Documenter dialog box, click the Queries tab and select qryIntern. 
Click Options.

 c. For Query, include Properties and SQL.

 d. From the Include for Fields section, choose Nothing.

 e. From the Include for Indexes section, choose Nothing.

 f. Click OK twice to go to Print Preview.

- Save a Database Documenter report by following these steps:

 a.  From the Print Preview tab, in the Data group, click PDF or XPS  to 
save the printout as a file.

 b. Save the file as a PDF and name the file [your initials]-06-23-A.

 c. Depending on your class procedures, print or turn in the PDF file.

 d. Close Print Preview.

Exercise 6-24
You have been asked to create a query to display the number of beds per 
facility, but only for nonprofit facilities.

1. The database [your initials]-EcoMed-06 is required to complete this 
exercise.

a. Open and enable content for [your initials]-EcoMed-06.

2. Create a query in Design View by following these steps:

a. From the Create tab, in the Queries group, click Query Design .

b. In the Show Table dialog box, double-click tblFacilities and 
tblManageType. Click Close.

c. Resize the Field List so all fields can be seen.

d. From the tblFacilities Field List, double-click FacName and Beds.

e. From the tblManageType Field List, double-click ManageType.

f. From the Quick Access toolbar, click Save . Name the query 
qryNonProfitBeds.

3. Add a criterion to a field by following these steps:

a. In the Criteria row for ManageType, key *nonprofit*.

06-23-A.pdf 
1 Page
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4. Sort and show the top 5 percent of records by following these steps:

a.  In the Sort row for Beds, click the drop-down arrow and choose 
Descending.

b.  From the Design tab, in the Query Setup group, click Return  and 
then choose 5%.

c. Switch to Datasheet View to the see the resulting 6 records.

d. Save and close the query.

Assessment

-  According to your classroom procedure, turn in your database only when 
you have completed all assigned exercises.

-OR-

-  Create a Database Documenter report for qryNonProfitBeds following 
these steps:

 a.  From the Database Tools tab, in the Analyze group, click Database 
Documenter.

 b.  In the Documenter dialog box, click the Queries tab and select 
qryNonProfitBeds. Click Options.

 c. For Query, include Properties and SQL.

 d. From the Include for Fields section, choose Nothing.

 e. From the Include for Indexes section, choose Nothing.

 f. Click OK twice to go to Print Preview.

- Save a Database Documenter report by following these steps:

 a.  From the Print Preview tab, in the Data group, click PDF or XPS  to 
save the printout as a file.

 b. Save the file as a PDF and name the file [your initials]-06-24-A.

 c. Depending on your class procedures, print or turn in the PDF file.

 d. Close Print Preview.

Exercise 6-25
Create a PivotChart to display the number of leave dates taken by 
employees.

1. The database [your initials]-EcoMed-06 is required to complete this 
exercise.

a. Open and enable content for [your initials]-EcoMed-06.

2. Create a query in Design View by following these steps:

a.  From the Create tab, in the Queries group, click Query Design .

b.  In the Show Table dialog box, double-click tblEmployees and 
tblLeaveDays. Click Close.

06-24-A.pdf 
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c. Resize the Field List so all fields can be seen.

d. From the tblEmployees Field List, double-click JobCode.

e.  From the tblLeaveDays Field List, double-click LeaveDate and 
LeaveCategory.

f.  From the Quick Access toolbar, click Save . Name the query 
qryEmpLeaveChart.

3. Add a criterion by following these steps:

a. In the Criteria row for JobCode, key m*.

4. Modify a PivotChart view by following these steps:

a.  Switch to PivotChart View. From the Chart Field List, click the Expand 
button for LeaveDate By Month. Drag the Months into the Drop 
Category Fields Here zone (bottom of the chart) of the PivotChart.

b.  From the Chart Field List, drag the LeaveCategory into the Drop Series 
Fields Here zone (right of the chart) of the PivotChart.

c.  From the Chart Field List, drag the LeaveCategory into the Drop Data 
Fields Here zone (middle of the chart) of the PivotChart. The default 
function for this data type is Count.

d.  Close the Chart Field List. From the Design tab, in the Tools group, 
click Property Sheet .

e.  On the PivotChart, click the Value Axis Title (left of the chart). In the 
Properties dialog box, click the Format tab. Change the Caption 
property to Number of Days.

f.  On the PivotChart, click the Category Axis Title (bottom of the chart). 
In the Properties dialog box, change the Caption property to Year to 
Date. Close the Properties dialog box.

g.  From the Design tab, in the Show/Hide group, click Drop Zone  to 
remove the zone markers.

h.  From the Design tab, in the Show/Hide group, click Legend  to add 
the Legend to the PivotChart.

i. Save the query.

Assessment

-  According to your classroom procedure, turn in your database only when 
you have completed all assigned exercises.

-OR-

- Save a query’s PivotChart View by following these steps:

 a. Click the File tab. From the Print option, choose Print Preview .

 b. From the Print Preview tab, in the Page Layout group, click Landscape .

 c.  From the Print Preview tab, in the Data group, click PDF or XPS  to 
save the printout as a file.

 d. Save the file as a PDF and name the file [your initials]-06-25-A.

 e. Depending on your class procedures, print or turn in the PDF file.

 f. Close Print Preview and the query.
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-  Create a Database Documenter report for qryEmpLeaveChart following 
these steps:

 a.  From the Database Tools tab, in the Analyze group, click Database 
Documenter.

 b.  In the Documenter dialog box, click the Queries tab and select qryIntern. 
Click Options.

 c. For Query, include Properties and SQL.

 d. From the Include for Fields section, choose Nothing.

 e. From the Include for Indexes section, choose Nothing.

 f. Click OK twice to go to Print Preview.

- Save a Database Documenter report by following these steps:

 a.  From the Print Preview tab, in the Data group, click PDF or XPS  to 
save the printout as a file.

 b. Save the file as a PDF and name the file [your initials]-06-25-B.

 c. Depending on your class procedures, print or turn in the PDF file.

 d. Close Print Preview.

06-25-B.pdf 
1 Page
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Lesson Applications

06-26-A.pdf 
1 Page

Exercise 6-26
Create a query to display the name of the management company, the name 
of the facility, and the state in which the facility is located. Display only 
records from region 2.

1. Open and enable [your initials]-EcoMed-06.

2. Launch the Simple Query Wizard.

3. From tblManagement use the fields ManageName.

4. From tblFacilities use the fields FacName, State, and Region.

5. Save the query as qryRegion2.

6. Sort the dynaset in ascending order by ManageName.

7. Only show records that are from Region 2.

8. Review the 9 records. Save and close the query.

Assessment

-  According to your classroom procedure, turn in your database only when 
you have completed all assigned exercises.

-OR-

-  Create a Database Documenter report for qryRegion2 using the following 
settings:

• Include for Query: Properties, SQL

• Include for Fields: Nothing

• Include for Indexes: Nothing

- Save the Documenter report as a PDF file named [your initials]-06-26-A.

- According to your class procedures, print or turn in the PDF file.

Exercise 6-27
Create a query to display the names and addresses of your employees. 
Display the city, state, and zip code of the employees in a format that can 
be used on mailing labels.

1. Using [your initials]-EcoMed-06, create a new query in Design View.

2. From tblEmployees, add the fields FirstName, LastName, Address, City, 
State, and PostalCode.

3. Save the query as qryEmpAddress.

4. Create a calculated field that will concatenate FirstName and LastName 
with a space between the fields.
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5. Change the alias of the first calculated field to FullName.

6. Create a calculated field that will concatenate City, State, and 
PostalCode using “, ” between City and State and two spaces between 
State and PostalCode.

7. Change the alias of the second calculated field to Address2.

8. Sort the dynaset in descending order by LastName.

9. Display only the fields FullName, Address, and Address2 in this order.

Assessment

-  According to your classroom procedure, turn in your database only when 
you have completed all assigned exercises.

-OR-

-  Create a Database Documenter report for qryEmpAddress using the 
following settings:

• Include for Query: Properties, SQL

• Include for Fields: Nothing

• Include for Indexes: Nothing

- Save the Documenter report as a PDF file named [your initials]-06-27-A.

- According to your class procedures, print or turn in the PDF file.

Exercise 6-28
Create a query to display names and job codes of employees. Also include 
the leave categories and leave dates. Convert the query to a PivotChart.

1. Using [your initials]-EcoMed-06, create a new query in Design View.

2. Include tblEmployees  and tblLeaveDays.

3. From tblEmployees, add LastName, FirstName, and JobCode.

4. From tblLeaveDays, add LeaveCategory and LeaveDate.

5. Name the query qryLeaveByJob.

6. Create a PivotChart, using the following settings:

 • Add JobCode to the x-axis.

 • Add LeaveCategory to the Legend. Add the Legend to the chart.

 •  Add LeaveDate to the Data area of the chart with a default function 
of Count.

 • Rename the x-axis Job Codes-[your full name].

 • Rename the y-axis to Count.

 • Remove the drop zones.
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Assessment

-  According to your classroom procedure, turn in your database only when 
you have completed all assigned exercises.

-OR-

-  Save the PivotChart View in Landscape as a PDF. Name the file 
[your initials]-06-28-A.

- According to your class procedures, print or turn in the PDF file.

Exercise 6-29  Challenge Yourself
Create a PivotChart to the revenue of facilities in relationship to the type 
of management structure to which the facility reports.

1. Using [your initials]-EcoMed-06, create a new query in Design View.

2. Include tblManagement, tblFacilities, and tblManageType.

3. From tblManagement, add ManageName.

4. From tblManageType, add ManageType.

5. From tblFacilities, add FacName, State, and Revenue.

6. Only show records that have any governmental ManageType.

7. Save the query as qryGovRevChart.

8. Add a calculated field named Rev that will divide the Revenue by 
1 million (1,000,000).

9. Create a PivotChart, using the following settings:

 • Add State to the x-axis.

 • Add ManageType to the Legend. Add the Legend to the chart.

 • Add Rev to the Data area with a default function of SUM.

 • Rename the x-axis to States-[your full name].

 • Rename the y-axis to Total Revenue (In Millions).

 • Remove the drop zones.

Assessment

- Save and close the query.

-  According to your classroom procedure, turn in your database only when 
you have completed all assigned exercises.

-OR-

-  Save the PivotChart View in Landscape as a PDF. Name the file 
[your initials]-06-29-A.

- According to your class procedures, print or turn in the PDF file.

06-28-A.pdf 
1 Page
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- Save and close the query.

-  Create a Database Documenter report for qryGovRevChart using the 
following settings:

• Include for Query: Properties, SQL

• Include for Fields: Nothing

• Include for Indexes: Nothing

- Save the Documenter report as a PDF file named [your initials]
-06-29-B.

- According to your class procedures, print or turn in the PDF file.

On Your Own

In these exercises you work on your own, as you would in a real-life work 
environment. Use the skills you’ve learned to accomplish the task—and be 
creative.

Exercise 6-30
Review the design of the database that you modified in Exercise 5-28. On a 
sheet of paper, list information that a user of your database might need. 
Design three queries that might provide the information needed. Use a variety 
of query types. Write your name and Exercise 6-30. Before proceeding to the 
next exercise, have your instructor approve your database design and 
intentions. Continue to the next exercise.

Exercise 6-31
Create the queries you designed in Exercise 6-30. Enter at least five additional 
records into each table of the database. Print the tables. Review the design of 
the database. On a sheet of paper, design a dynaset that incorporates data from 
two or more tables. Identify the type of query needed to create the dynaset. On 
the same sheet of paper, list all fields to be used in the query. For each field, 
include the name of the table from which the field originates. Identify the 
key fields and any foreign fields. Write down the criteria that would be 
required for the query. Name the query appropriately. Write your name and 
Exercise 6-31 on each sketch. Continue to the next exercise.

Exercise 6-32
Based on the designs that you created in Exercises 6-30 and 6-31, create the 
queries. Print the definitions for each query. Print a copy of the dynaset for 
each query. Submit to your instructor the designs and printouts that you 
created for Exercises 6-30 through 6-32. Keep a copy of the database you 
modified in this exercise. You will use it for the On Your Own exercises in 
subsequent lessons.
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